首页 新闻 搜索 专区 学院

一个asp.net在在本机没有在在服务器上出现的问题

0
悬赏园豆:20 [已解决问题] 解决于 2010-12-14 18:01
<table width="100%" bgcolor="#ffffcc"> <tbody> <tr> <td> <pre> &lt;add assembly="System.Windows.Forms, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/&gt;<br /> &lt;add assembly="System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/&gt;<br /><span style="color: red;"> &lt;add assembly="System.Web.DataVisualization, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/&gt;&lt;/assemblies&gt;<br /></span> &lt;/compilation&gt;<br /><br /></pre> </td> </tr> </tbody> </table> <p> <br /><strong>&nbsp;</strong><br /><br /><strong>Assembly Load Trace:</strong> The following information can be helpful to determine why the assembly 'System.Web.DataVisualization, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' could not be loaded.<br /><br /></p> <table width="100%" bgcolor="#ffffcc"> <tbody> <tr> <td> <pre>WRN: Assembly binding logging is turned OFF.<br />To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.<br />Note: There is some performance penalty associated with assembly bind failure logging.<br />To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].<br /></pre> </td> </tr> </tbody> </table>
问题补充: 多谢各位了,虽然没采用你们的但还是给分
山间故人的主页 山间故人 | 初学一级 | 园豆:80
提问于:2010-11-29 17:27
< >
分享
最佳答案
0

你用的IIS服务器支持不到.net3.5吧,你用.net2.0的项目试试就没这个问题了。

收获园豆:4
yearN | 小虾三级 |园豆:551 | 2010-12-14 13:32
其他回答(4)
0

服务器的.net framework版本是多少,是否和本机一样。

收获园豆:4
Astar | 园豆:40805 (高人七级) | 2010-11-29 18:21
0

应该是平台版本的问题额

收获园豆:4
Specialaspnet | 园豆:70 (初学一级) | 2010-11-29 21:25
0

你的config里面显示为3.5的环境,检查服务器是否是一样的环境,如果没问题就将config删掉,重新生成试一下。

收获园豆:4
勤劳的渔网工作者 | 园豆:572 (小虾三级) | 2010-11-29 23:34
0

framework版本问题。要不就把这个配置删掉试试

收获园豆:4
茂茂 | 园豆:2887 (老鸟四级) | 2010-11-30 09:14
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册