首页 新闻 搜索 专区 学院

eclipse 3.6 装了wtp插件,创建flex j2ee项目。

1
悬赏园豆:140 [待解决问题]

!ENTRY com.adobe.flexbuilder.project 4 43 2011-02-18 16:58:16.480
!MESSAGE Error in ActionScript Project wizard
!STACK 0
java.lang.reflect.InvocationTargetException
 at com.adobe.flexbuilder.project.ui.wizards.AbstractFlexProjectWizard$FlexStrategy$2.run(AbstractFlexProjectWizard.java:796)
 at org.eclipse.jface.operation.ModalContext$ModalContextThread.run(ModalContext.java:121)
Caused by: org.eclipse.core.runtime.CoreException: One or more constraints have not been satisfied.
 at org.eclipse.wst.common.project.facet.core.internal.FacetedProject.modifyInternal(FacetedProject.java:364)
 at org.eclipse.wst.common.project.facet.core.internal.FacetedProject.mergeChangesInternal(FacetedProject.java:1182)
 at org.eclipse.wst.common.project.facet.core.internal.FacetedProject.access$2(FacetedProject.java:1118)
 at org.eclipse.wst.common.project.facet.core.internal.FacetedProject$1.run(FacetedProject.java:325)
 at org.eclipse.core.internal.resources.Workspace.run(Workspace.java:1975)
 at org.eclipse.wst.common.project.facet.core.internal.FacetedProject.modify(FacetedProject.java:340)
 at com.adobe.flexbuilder.project.ui.wizards.FlexProjectWtpHelper.addJ2eeFacets(FlexProjectWtpHelper.java:250)
 at com.adobe.flexbuilder.project.ui.wizards.FlexProjectWtpHelper.performFinish(FlexProjectWtpHelper.java:142)
 at com.adobe.flexbuilder.project.ui.wizards.AbstractFlexProjectWizard$FlexStrategy$2.run(AbstractFlexProjectWizard.java:794)
 ... 1 more
Root exception:
org.eclipse.core.runtime.CoreException: One or more constraints have not been satisfied.
 at org.eclipse.wst.common.project.facet.core.internal.FacetedProject.modifyInternal(FacetedProject.java:364)
 at org.eclipse.wst.common.project.facet.core.internal.FacetedProject.mergeChangesInternal(FacetedProject.java:1182)
 at org.eclipse.wst.common.project.facet.core.internal.FacetedProject.access$2(FacetedProject.java:1118)
 at org.eclipse.wst.common.project.facet.core.internal.FacetedProject$1.run(FacetedProject.java:325)
 at org.eclipse.core.internal.resources.Workspace.run(Workspace.java:1975)
 at org.eclipse.wst.common.project.facet.core.internal.FacetedProject.modify(FacetedProject.java:340)
 at com.adobe.flexbuilder.project.ui.wizards.FlexProjectWtpHelper.addJ2eeFacets(FlexProjectWtpHelper.java:250)
 at com.adobe.flexbuilder.project.ui.wizards.FlexProjectWtpHelper.performFinish(FlexProjectWtpHelper.java:142)
 at com.adobe.flexbuilder.project.ui.wizards.AbstractFlexProjectWizard$FlexStrategy$2.run(AbstractFlexProjectWizard.java:794)
 at org.eclipse.jface.operation.ModalContext$ModalContextThread.run(ModalContext.java:121)
Contains: Dynamic Web Module 3.0 requires Java 1.6 or newer.

问题补充: eclipse 是adobe的 flex builder burrito
五六的主页 五六 | 初学一级 | 园豆:60
提问于:2011-02-18 17:21
< >
分享
所有回答(1)
0

估计是JDK版本不对吧?

日志中 Dynamic Web Module 3.0 requires Java 1.6 or newer 这个

使用1.6或以上的版本估计就可以了

2012 | 园豆:21133 (高人七级) | 2011-02-25 12:09
可是我用的已经是1.6的JDK了!无助了!
支持(0) 反对(0) 五六 | 园豆:60 (初学一级) | 2011-03-02 14:50
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册