首页 新闻 搜索 专区 学院

linq to xml 能在 .net2.0中使用吗?

0
[已关闭问题]
因为在程序中大量地使用xml操作,所以使用了linq to xml(很方便),但是这需要 .net3.5支持,在<br>部署时麻烦就大了,开发的程序就10M,但是部署时为了包含.net3.5就200M了。<br>能不能有什么办法使其支持.net2.0?这样就好了!<br>
apan的主页 apan | 初学一级 | 园豆:190
提问于:2008-08-15 23:06
< >
分享
其他回答(1)
0
.netv2.0.50727或以上就可以,不过要将应该复制的DLL复制全了
重典 | 园豆:2442 (老鸟四级) | 2008-08-15 23:11
0
拿到只装了.net 2.0的机子上,运行时会有Exception扔出来,会说明缺了哪些dll. 不会影响稳定性. 另外,你可以试一下vs 2008 sp1里新增的.net client profile,这个只有26M左右,包含了大部分客户端软件需要的类库.
deerchao | 园豆:8167 (大侠五级) | 2008-08-16 02:01
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册