首页 新闻 搜索 专区 学院

为何安装ef4.1后在VS中组件库里的System.Data.Entity仍为4.0

0
悬赏园豆:20 [待解决问题]

如题~~~~~~

在微软官网下载的EntityFramework41.exe安装包,安装成功后在VS2010中新建entity framework项目,可是新建项目引入的entity framework仍然是4.0的

引用-》添加引用-》.Net里面看System.Data.Entity版本也是4.0

coolray的主页 coolray | 初学一级 | 园豆:165
提问于:2011-08-11 10:02
< >
分享
所有回答(4)
0

我也有同样地问题

specimen | 园豆:205 (菜鸟二级) | 2011-09-06 17:20
0

安装完EntityFramework41.exe安装包之后,重新打开VS2010,

项目里之前的引用都不要删,直接添加新的.Net引用,选择组件名称为"EntityFramework"的

学习分享 | 园豆:209 (菜鸟二级) | 2011-11-30 18:13
0

这个我知道 给我分吧 我没分了

  上面说的我都试验过了,都不可能成功为4.1,其实是这样的,你引用上去的时候确实是4.1,但是.NET会帮你编译成4.0的,可能是框架是4.0的吧,不过没关系,不影响你,

   是不是在一个MVC3.0教程中看到一个DB什么的,4.0的打不出来,把前面省略,直接BASE那里开始

命若天定-破天 | 园豆:1 (初学一级) | 2012-02-27 17:39
0
张 博 | 园豆:206 (菜鸟二级) | 2012-06-09 18:13
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册