首页新闻找找看学习计划

LINQPad 使用EF4.2 POCO有问题

0
[已解决问题] 解决于 2012-04-20 09:13

请问我在使用LINQPad加载,使用ef4.2写的程序集时,总报无法加载程序集EntityFramework.dll

版本4.2.0.0,系统找不到指定文件。各位大侠可有解决方案啊

ef
问题补充:

哦,我把ef换回4.1 update1了,用的vs2010 .net 4.0

做出来的程序集用LINQPad加载依然包这样的错,只是版本变4.1.0.0了,还是找不到,我把我的程序集合EF4.1Update1的程序集都放一起,且我的ef是安装的。

郁闷啊。。。

Apex.ma的主页 Apex.ma | 初学一级 | 园豆:200
提问于:2011-11-16 17:14
< >
分享
最佳答案
0

你的.NET Framework和VS是什么版本的?EF4.2是最新出来的,现在一般用的是4.1(VS2010 SP1+.NET Framework 4.0),Entity Framework 4.2要等到.NET Framework 4.5才能完全支持

奖励园豆:5
artwl | 专家六级 |园豆:16526 | 2011-11-16 17:45

哦,我把ef换回4.1 update1了,用的vs2010 .net 4.0

做出来的程序集用LINQPad加载依然包这样的错,只是版本变4.1.0.0了,还是找不到,我把我的程序集合EF4.1Update1的程序集都放一起,且我的ef是安装的。

郁闷啊。。。

Apex.ma | 园豆:200 (初学一级) | 2011-11-17 15:07
其他回答(1)
0

得用新版的,多了一个driver EntityFramework POCO

但现在网上破解版最新到4.3.1,还不支持。。。

用新版又没智能提示。。。

Neo Zhou | 园豆:202 (菜鸟二级) | 2012-11-21 14:19
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册