首页新闻找找看学习计划

maven编译geoserver源码问题,求助!

0
悬赏园豆:30 [待解决问题]

我用maven编译geoserver源码,出现了下面的问题,望牛人帮我解答。

[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal org.apache.maven.plugins:maven-plugin-plugin:2.9:
descriptor (default-descriptor) on project config: The API of the mojo scanner i
s not compatible with this plugin version. Please check the plugin dependencies
configured in the POM and ensure the versions match. org.apache.maven.tools.plug
in.scanner.MojoScanner.populatePluginDescriptor(Lorg/apache/maven/tools/plugin/P
luginToolsRequest;)V -> [Help 1]
[ERROR]
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e swit
ch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR]
[ERROR] For more information about the errors and possible solutions, please rea
d the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MojoExecutionE
xception
[ERROR]
[ERROR] After correcting the problems, you can resume the build with the command

[ERROR] mvn <goals> -rf :config

貌似是说插件和工程中pom文件中的版本不兼容。困扰我好几天了。希望各位给予知道,不甚感激!!

maven版本:3.0.4

geoserver版本:2.1.3

夏士莲007的主页 夏士莲007 | 初学一级 | 园豆:172
提问于:2012-03-23 22:56
< >
分享
所有回答(5)
0

我也是这个问题,找了一天了都没有解决。你解决没有啊?解决请告诉我怎么弄啊?winnie198465@sina.com

winnie198465 | 园豆:202 (菜鸟二级) | 2012-06-08 16:08
0

把maven的版本换成2.2.1就可以了

张庆旭 | 园豆:202 (菜鸟二级) | 2012-06-12 14:50
0

可以运行mvn -e,看看错误详情先

_约_定 | 园豆:208 (菜鸟二级) | 2012-08-08 09:38
0

你好 我现在也遇到了这样的问题 我的Maven 用的3.2.3

Longlone | 园豆:202 (菜鸟二级) | 2014-10-08 16:50
0

最后,怎么解决了???新手,项目打开的时候,有错误啊,跪求qq:1482037582

lixue | 园豆:202 (菜鸟二级) | 2015-03-23 13:51
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册