首页 新闻 搜索 专区 学院

都来帮帮忙吧

0
悬赏园豆:20 [已解决问题] 解决于 2012-04-07 22:18

是怎么回事!

小兴o………o的主页 小兴o………o | 初学一级 | 园豆:141
提问于:2012-03-29 19:15
< >
分享
最佳答案
0

你的数据库服务器版本不够,无法附加高版本的数据库文件,两种方案:第一、升级数据库;第二:找个能打开的,导出这个数据库的脚本,然后在你的服务器上运行脚本就行,或者把数据库文件导出到Excel中,再从Excel文件导入到你的数据库中。

收获园豆:10
轻狂の书生 | 小虾三级 |园豆:1040 | 2012-03-31 11:51
其他回答(4)
0

目测估计是在Sql Server 2008上附加Sql Server 2008 R2版本的数据库。可以把原来的数据库导出脚本,然后再创建数据库。

wenthink | 园豆:415 (菜鸟二级) | 2012-03-29 19:23
0

数据库版本问题,高版本的数据库文件无法附加到低版本的数据库上

收获园豆:5
artwl | 园豆:16526 (专家六级) | 2012-03-29 19:26
0

你本机上的sql server的版本低于你要附加的数据库的版本。去网上找一个sql server 2008R2版本的。

松竹柏柳 | 园豆:38 (初学一级) | 2012-03-30 11:54
0

根本原因估计你使用的是SQLEXPRESS版本,附加失败,你可以用别的电脑该数据库备份还原,或者直接换个开发版或者企业版的数据库省得麻烦。还有可能是版本过低、

收获园豆:5
Halower | 园豆:1723 (小虾三级) | 2012-04-02 17:39
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册