首页 新闻 搜索 专区 学院

Eclipse中开发Android项目遇到编译错误

0
悬赏园豆:10 [已解决问题] 解决于 2012-05-08 10:38

五一假期结束后,我开始学习Android开发。今天根据网上介绍的步骤搭好了开发环境,并打算以“Create project from existing source”的方式创建一个新工程。“existing source”来自Android SDK(我的计算机上的路径是:D:\Program Files\android-sdk_r18-windows\android-sdk-windows\samples\android-15\ApiDemos)。可是工程编译出错:“

Description Resource Path Location Type
The method compare(LoaderCustom.AppEntry, LoaderCustom.AppEntry) of type new Comparator<LoaderCustom.AppEntry>(){} must override a superclass methodLoaderCustom.java/ApiDemos/src/com/example/android/apis/appline 152Java Problem

”,如上图所示。不知道是什么原因造成的,也不知道如何消除。请各位大侠帮忙!

leizisdu的主页 leizisdu | 初学一级 | 园豆:188
提问于:2012-05-04 22:30
< >
分享
最佳答案
0

"must override a superclass"

可能是你没有重写几类的方法!!

收获园豆:10
Angkor--:-- | 小虾三级 |园豆:1086 | 2012-05-05 19:32

谢谢您的解答!可是应该怎样重写基类?在学习Android过程中发现需要具备Java相关的知识,可我以前也没有学过Java,所以您能说的再具体点儿吗,如何重写基类?

leizisdu | 园豆:188 (初学一级) | 2012-05-06 19:19

@leizisdu: super.Create(Bundle savedInstanceState)

Angkor--:-- | 园豆:1086 (小虾三级) | 2012-05-10 09:44
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册