首页新闻招聘找找看知识库

请问Asp.net3.5能否与vs2005一同使用

0
悬赏园豆:20 [已关闭问题]

因为最近想学习asp.net mvc.结果发现要asp.net3.5才能使用,但可怜机器的配置不行,跑不起vs2008(内存,硬盘都不够,本人还是学生,也没money去升级机器).所以特来问问vs2005能与asp.net3.5一同工作吗?

父辈的旗帜的主页 父辈的旗帜 | 初学一级 | 园豆:2
提问于:2008-11-02 23:42
< >
分享
所有回答(8)
0

应该能吧。下个3.5的framework,再下个MVC BETA安装上去。园子里不是有08下装不上MVC模板的问题。在05下也应该一样吧。

能了理你的心情,俺也是学生。但我的是二G的内存,不过我的硬盘也不够用了。安装后VS08后就吧VS05删了,最近出了红擎三,郁闷安装包就6G多,玩不了了~

Astar | 园豆:40785 (高人七级) | 2008-11-02 23:54
0

VS2005可以与.net 3.5一起工作,但是VS2005默认创建的是.net2.0的项目。

VS2008运行时要比VS2005节省资源。

上不了岸的鱼 | 园豆:4611 (老鸟四级) | 2008-11-02 23:55
0

可以一起使用。

安装.NET 3.5以后,Framework里面的一些模板就自动加载到VS2005中了,这时候你只要在创建项目的时候,选择你需要的模板,比如说:asp.net mvc。

这时候,你创建的项目就是在.NET 3.5环境下面了。你可以测试一下:在安装了.NET3.5环境的VS2005上创建一个.NET 3.5的项目,然后放到未安装.NET 3.5的机器上运行,应该就会报错说缺少.NET 3.5的环境。

Lorn | 园豆:205 (菜鸟二级) | 2008-11-03 09:17
0

貌似要VS2005 SP1才可以,只是对linq和扩展方法没Intellisense吧。

LZ不行就装Visual Studio 2008 Express Edition吧,那个省点,还免费。

@Astar

我也想装红警三,不过它非得装6个G在C盘,我C盘剩余空间才4G不到……好不容易我想玩个游戏,就这么被打击了。

JimLiu | 园豆:300 (菜鸟二级) | 2008-11-03 10:11
0

难道你们编译时都不会报错吗?

RicoRui | 园豆:3663 (老鸟四级) | 2008-11-03 11:00
0

我以前也是安装vs2005的,看帮助文件上面好像不能直接运行asp.net3.5,需要升级补丁才可以。或者加引用(没有试过,网上搜索的)。如果升级不如直接安装vs2008,运行比05感觉要快一点,我也才2G内存

XBW | 园豆:404 (菜鸟二级) | 2008-11-03 15:52
0

可以一起使用

Geeks | 园豆:560 (小虾三级) | 2008-11-03 16:51
0

当然可以 .我以前都是vs2003,vs2005,vs2008安装在一起都可以使用的噢

索马 | 园豆:100 (初学一级) | 2008-11-04 11:56
你NB,3个一起用!
andyhao | 园豆:200 (初学一级) | 2009-09-08 17:06
   您需要登录以后才能回答,未注册用户请先注册