首页新闻招聘找找看知识库

想问下 Asp.Net MVC Beta 能否运行在 .Net 2.0下。

0
悬赏园豆:200 [已解决问题]

想问下 Asp.Net MVC Beta 能否运行在 .Net 2.0下具体方法如何实施。在 G.Cn上查了没找到。有一些以前版本的方法但是试了不行。谢谢各位。公司没使用3.5的空间(价格高而且好多空间都不支持3.5 )

elaner的主页 elaner | 初学一级 | 园豆:0
提问于:2008-11-26 13:02
最佳答案
1

不可以,asp.net mvc beta指明了要用3.5,没办法了

不过你后面那句话,我觉得不太对,现在多数.net2.0的空间事实上都是支持3.5的,因为在IIS配置中3.0/3.5并没有单独的选项,所以ISP对外公布都是按IIS中显示的2.0公布的

ISP的服务器一般都会保持自动更新,而.net framework3.5作为自动更新的一部分,基本上都已经被安装了

所以我建议不妨先在空间里上传几个测试文件,用一下.net3.5的东西看是否能够运行,我估计是能行的

祝好运

丁学 | 专家六级 |园豆:18530 | 2008-11-26 13:44
其他回答(7)
0

不可以吧,之前已经有人问过这个问题了

上不了岸的鱼 | 园豆:4611 (老鸟四级) | 2008-11-26 13:46
0

理论上说是可以的。实际上。。。也是可以的,就是麻烦点。

参考:

http://www.cnblogs.com/chsword/archive/2008/08/06/dotnetmvcframeworknet2_0.html

第一控制.NET | 园豆:1245 (小虾三级) | 2008-11-26 13:51
0

虚拟主机就不可以了,权限问题.

Astar | 园豆:40785 (高人七级) | 2008-11-26 14:18
0

应该可以的!

子夜星辰 | 园豆:1613 (小虾三级) | 2008-11-26 14:25
0

ASP.NET MVC Beta版可用于.NET 3.5和.NET 3.5 SP1下,同时支持VS 2008 和 Visual Web Developer 2008 Express SP1版本(该版本是免费的,现在还支持类库和web应用项目类型)。

生鱼片 | 园豆:5757 (大侠五级) | 2008-11-26 14:28
0

二进制代码 2.0和3.5都是一样的 应该也是可以的.

把所有需要的dll都部署到bin目录应该就可以了

 

iis的配置是需要权限的.但是也可以用其他方法或者加扩展名的方法来实现.园子里面有很多url重写的方法会这个道理是通用的

午夜瞎想 | 园豆:192 (初学一级) | 2008-11-26 23:21
0

asp.net mvc beta指明了要用3.5,但是它的runtime是2.0

你可以将它布暑到2.0/iis6上,但是最好使用vs2008来做这个站

所注意的是aspx页中 不使用C#3.0语法 即可

 

至于iis配置,虚拟主机一般不提供无扩展名或.mvc的,不过你可以用asbx或ashx

重典 | 园豆:2442 (老鸟四级) | 2008-11-27 09:22
http://idc.valu.cn 支持 asp.net 3.5 mvc
威流 | 园豆:200 (初学一级) | 2009-10-31 00:30
   您需要登录以后才能回答,未注册用户请先注册