首页新闻找找看学习计划

怎么把解决方案里所有程序集引用的framework版本从2.0升级到4.0?

0
悬赏园豆:30 [待解决问题]

用的是vs2010,最近想把项目从framework2.0升级到4.0?有没有便捷的方式?

不会只能把一个个程序集单独改引用的framework版本吧?

jerry li的主页 jerry li | 初学一级 | 园豆:177
提问于:2012-08-22 15:05
< >
分享
所有回答(7)
0

好像只能在项目的属性里面更改版本。

MNight | 园豆:180 (初学一级) | 2012-08-22 15:44
0

点击右键,点击属性页-选择目标framework,如果是类库项目,选择属性-目标框架,选择你想要的版本就行了

Impossible | 园豆:70 (初学一级) | 2012-08-22 15:58

“不会只能把一个个程序集单独改引用的framework版本吧?”----我的意思是:是不是只能一个个单独的改,有没有便捷的方式把整个项目下所有的程序集一并都改了。

请看清楚题目再回答吧

支持(0) 反对(0) jerry li | 园豆:177 (初学一级) | 2012-08-22 16:07

@jerry li: 没有,也不会那样,谁知道你其他的程序集是不是要整成一样的版本

支持(0) 反对(0) Impossible | 园豆:70 (初学一级) | 2012-08-22 16:08
0

把项目转成4.0的就行了

天*^o^*.使 | 园豆:140 (初学一级) | 2012-08-22 18:17
0

你用vs2010打开,然后在你的项目属性,选在.net framework 4.0 即可。

chenping2008 | 园豆:9836 (大侠五级) | 2012-08-22 19:13
0

修改成4.0之后,可能有些DDL引用会出错,需要手动更新引用……

Alec-Yin | 园豆:188 (初学一级) | 2012-08-22 22:19
0

吧web.config文件中重要的东西保存起来,然后把web.config删掉(删掉之前先备份),然后用vs2010打开,编译运行吧错误修正一下。

可能会有一些bug。

唯吴独尊 | 园豆:707 (小虾三级) | 2012-08-23 21:21
0

用2010打开,直接把项目转成4.0的就行了

Philomena | 园豆:154 (初学一级) | 2012-08-24 14:26
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册