首页 新闻 搜索 专区 学院

如何使用特定的.net版本编译程序?

0
悬赏园豆:10 [已解决问题] 解决于 2007-11-15 11:33
<P>如何使用特定的.net版本编译程序?</P> <P>比如说,我以前这个项目是在1.1下做的,我现在想转换为2.0的版本。</P>
问题补充: 如果没有VS呢? 可以在命令行下操作吗? 如何知道程序所需要的.net版本?
逖靖寒的主页 逖靖寒 | 菜鸟二级 | 园豆:265
提问于:2007-11-12 13:34
< >
分享
最佳答案
0
当然可以,以前有人以记事本+编译器的开发方式称为大牛,不过不可取,吃饱了撑着…… http://msdn2.microsoft.com/zh-cn/library/2fdbz5xd(VS.80).aspx 帮你找了MS的这些,当然远不止那么简单啦,需要您自己深入挖掘,可以参考一下VS里面的编译器参数! 至于aspx的,页面时不需要编译的,只有.cs的文件才需要编译……aspx将由IIS代为预编译,在第一次运行的时候就会…… 1.1到2.0,你有的事东西要改……
volnet(可以叫我大V) | 小虾三级 |园豆:720 | 2007-11-12 17:08
其他回答(4)
0
用2005直接打开1.1的程序,按提示一步步进行转换~
没剑 | 园豆:430 (菜鸟二级) | 2007-11-12 13:37
0
vs2008好像可以﹐用過的網友說說 我現在裝一個vs2003﹐再裝一個vs2005﹐好像沒有好辦法
Kevin Zou | 园豆:218 (菜鸟二级) | 2007-11-12 15:54
0
Visual Studio 2008 只支持 .Net 2.0+ 的编译,并且用的编译器实质上是 3.5 的。要转换项目是再简单不过的,不过可能会发生少量兼容性问题,需要注意。2.0 - 3.0 - 3.5 是平滑过渡的,不会有问题;1.1 - 2.0 到是有可能。
随风流月 | 园豆:405 (菜鸟二级) | 2007-11-12 16:45
0
.NET Framework版本不同的. 还有,当你写这个程序的时候,就定下来应该是几点几了, VS2005就2.0,2003就1.1,怎么在编译时要选择版本呢? 好奇怪的问题 :) 好奇怪的回答 ~_*
zjy | 园豆:3194 (老鸟四级) | 2007-11-15 08:29
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册