首页 新闻 搜索 专区 学院

Eclipse创建android项目报错

0
悬赏园豆:5 [已解决问题] 解决于 2013-02-25 19:07

创建android项目

提示 this template requires a more recent  version of the android eclipse plugin. please update from version 20.0.0

我再 帮助栏选择 检查更新,完了重启,结果还是这样,不知道怎么解决。

东宫有喜的主页 东宫有喜 | 初学一级 | 园豆:3
提问于:2012-11-17 13:29
< >
分享
最佳答案
0

如果搞不清adt版本什么的,建议下个最新的eclispe,然后重装下adt

http://www.eclipse.org/

收获园豆:5
Luics | 菜鸟二级 |园豆:244 | 2012-11-21 02:01
其他回答(2)
0

ADT版本是多少?

__熊_ | 园豆:238 (菜鸟二级) | 2012-11-18 20:38
0

问题:

eclipse新建一个Android项目,就立即报错,不会自动产生.R文件,项目中正确无法导入.R文件。

 

解决方法:

今天被这个问题折腾了一下,最后终于找到了解决办法。

 

产生这个问题,是因为你升级了ADT到version 22,但是还需要升级SDK Tools,Platform Tools,Build Tools,如果没有安装后者升级后者,eclipse不会自动生成.R文件。


具体操作:
1、当你ADT升级到了22后,还需要升级或者安装以上SDK Tools,Platform Tools,Build Tools;

2、打开eclipse,点击进入Android SDK Manager,然后选择Tools下面的四项,直接安装或者升级;

3、等待几分钟安装好后。把 你的sdk目录\android-sdk\build-tools\ 添加到PATH(环境变量)中;

4、让PATH的修改生效:重启电脑或者百度搜一下“如何让PAHT修改立即生效”,按照操作即可;

5、最后重启eclipse,Project—>Clean工程,就会自动生成.R文件,没有错误。

zerogooo | 园豆:202 (菜鸟二级) | 2013-09-14 16:37
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册