首页 新闻 搜索 专区 学院

c# framework3.5中可以引用framework4.0中的功能么

0
悬赏园豆:10 [待解决问题]

我的程序是用framework3.5编译的。

后来发现需要使用一个framework4.0下命名间:System.Threading

类:CancellationTokenSource

于是我将3.5改成了4.0,重新编译后正常。但是运行调试中提示:

this assembly is built by a runtime newer than the currently loaded runtime newer than the currently loaded runtime and cannot be loaded.

谢军的主页 谢军 | 初学一级 | 园豆:3
提问于:2013-01-16 09:25
< >
分享
所有回答(3)
0

把你的exe所在的项目修改为.net 4.0。

Launcher | 园豆:45045 (高人七级) | 2013-01-16 10:06
0

你试试不就知道了

一叶兰舟飘 | 园豆:351 (菜鸟二级) | 2013-01-16 10:58
0

这里有你要的解决方案: http://blog.csdn.net/ws_hgo/article/details/6461227,希望能帮到你。

beyondchina | 园豆:680 (小虾三级) | 2013-03-26 21:44
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册