首页新闻找找看学习计划

VS2010调试时出现无法使用“。。。”附加到应用程序“webdev.webserver40.exe”

0
悬赏园豆:50 [已解决问题] 解决于 2013-04-13 17:05

各位大虾,小弟今天安装vs2010旗舰版后,运行调试一个项目时调试不了,能编译,按ctrl+f5 可以运行,但是就是调试就不行,提示的是:无法使用“XIAOQIANGZHOU”附加到应用程序“webdev.webserver40.exe(PID:2260)”,发生了通常表示被损坏的错误(代码0X80040155)。如果问题仍然存在则通过“控制面板”中的添加删除程序修复visual studio安装。
注:XIAOQIANGZHOU是我的电脑域名。
我在网上找了好久也没找到方法,然后我又重新修复安装,还是不行,弄了我半天还是没弄好的,所以到这里来请大家帮帮忙了,小弟在此拜谢了

xiaoqiangzhou的主页 xiaoqiangzhou | 初学一级 | 园豆:83
提问于:2013-03-28 11:13
< >
分享
最佳答案
0

以前在win7下安装VS2003的时候碰到过这种情况

但是的解决方案是

1. 控制面板-程序和功能-打开或关闭windows功能,找到“万维网服务-安全性-Windows 身份认证”,勾选,确定。

2. 在IIS中点击根目录,找到“ISAPI和CGI限制”,允许ASP.NET V1.14322。

3. IIS中点击具体应用程序,身份验证 - Windows 身份验证,允许。

楼主可以参考下试试

收获园豆:10
mib23 | 菜鸟二级 |园豆:216 | 2013-03-29 11:44

你好,你应该正对是iis7.0版本的吧,我电脑上的是5。1版本的

xiaoqiangzhou | 园豆:83 (初学一级) | 2013-03-29 15:04
其他回答(6)
0

173844862 .net高级交流群

收获园豆:10
辛巴 | 园豆:622 (小虾三级) | 2013-03-28 13:35

你好,请问你知道解决方案吗

支持(0) 反对(0) xiaoqiangzhou | 园豆:83 (初学一级) | 2013-03-28 15:13
0

请先清理解决方案,然后重新生成。如果有多个项目,请按照依赖顺序逐个生成

收获园豆:10
S-Lyy | 园豆:257 (菜鸟二级) | 2013-03-28 13:50

你好,这样尝试也没用,我自己新建一个网站然后对后台代码设立断点调试也照样提示那样的错误

我怀疑是不是我电脑的权限问题,不然怎么会提示我的电脑域名无法附加呢

支持(0) 反对(0) xiaoqiangzhou | 园豆:83 (初学一级) | 2013-03-28 15:12

@xiaoqiangzhou: 检查代码逻辑吧....  

支持(0) 反对(0) S-Lyy | 园豆:257 (菜鸟二级) | 2013-03-29 09:50
0

应该是安装问题,或者安装包本身就有问题。重新下一个试试……

收获园豆:10
滴答的雨 | 园豆:3690 (老鸟四级) | 2013-03-28 13:54

我同事也是安装这个版本的,没问题,到我电脑就出现问题了,悲剧,

实在不行我下一个专业版试试

支持(0) 反对(0) xiaoqiangzhou | 园豆:83 (初学一级) | 2013-03-28 15:13
0

你这个一般安装失败后修复就可以了。不要去删除然后重新安装。因为有其有些文件在注册表已经注册。不过还是可以完全删除的就是比较麻烦。尽量尝试修复!

收获园豆:10
伏草惟存 | 园豆:1420 (小虾三级) | 2013-03-28 19:06

你好 ,我安装修复了还是不行

支持(0) 反对(0) xiaoqiangzhou | 园豆:83 (初学一级) | 2013-03-28 21:07

@xiaoqiangzhou: 你是不是之前删除过,然后重新安装=》修复!这样不可以。(怕你删除不干净)

与其浪费一天的时间,不如30分钟重装个系统=》1小时左右重装系统(你再换个vs的包)

支持(0) 反对(0) 伏草惟存 | 园豆:1420 (小虾三级) | 2013-03-28 22:16

@卿君:你好,我没有删除过的,我电脑安装了03、05版本,重装系统的话,我的开发工具全部都要重新弄的

支持(0) 反对(0) xiaoqiangzhou | 园豆:83 (初学一级) | 2013-03-29 15:03
0

项目上右键,属性,调试。看下配置项。

luofer | 园豆:468 (菜鸟二级) | 2013-03-29 15:29

你好,配置项都是默认的啊,并没有改正什么,难道需要配置吗?

支持(0) 反对(0) xiaoqiangzhou | 园豆:83 (初学一级) | 2013-03-29 15:36

@xiaoqiangzhou: 我现在余遇到了这个问题,请问你是怎么样解决这个问题的呢

支持(0) 反对(0) shiqi | 园豆:202 (菜鸟二级) | 2014-11-06 17:05
0

 你好,我现在也遇到了这个问题,请问你的这个问题是怎么解决的,谢谢

shiqi | 园豆:202 (菜鸟二级) | 2014-11-06 17:04

你好请参考我的博文:http://www.cnblogs.com/xiaoqiangzhou/p/4080515.html

希望对你有帮助

支持(0) 反对(0) xiaoqiangzhou | 园豆:83 (初学一级) | 2014-11-07 09:59
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册