首页 新闻 搜索 专区 学院

win2003中的apache怎么样才能配置.NET4的web程序?

0
悬赏园豆:5 [已解决问题] 解决于 2013-12-30 17:15

服务器是2003,装了apache和。net4

我的.net4的web站点不用iis,怎么在apache下运行呢?

4.0以下是可以在mod_aspdotnet这软件,但是这个好像已经停止研究了,.net4我是没配置成功,有其他办法不?

夜星冷的主页 夜星冷 | 初学一级 | 园豆:71
提问于:2013-11-16 13:10
< >
分享
最佳答案
0

打開你的httpd文檔用我下面的script 就可以支持.netframework 4.0 及asp ajax 了:

######################################################

AliasMatch "^/(?i)aspnet_client/system_web/(\d+)_(\d+)_(\d+)_(\d+)/(.*)" \ "C:/Windows/Microsoft.NET/Framework/v$1.$2.$3/ASP.NETClientFiles/$4"

<Directory "C:/Windows/Microsoft.NET/Framework/v*/ASP.NETClientFiles">

Options FollowSymlinks Order allow,deny

Allow from all

</Directory>

AspNetVersion v4.0.30319

AspNetMount /ASP "C:/ASP"

Alias /ASP "C:/ASP" <Directory "C:/ASP">

Options FollowSymlinks Indexes

AspNet files

Order allow,deny

Allow from all

DirectoryIndex index.html index.aspx default.htm default.aspx

</Directory>

收获园豆:5
KKMAK | 菜鸟二级 |园豆:207 | 2013-11-30 21:36
其他回答(2)
0

用IIS运行站点,但绑定到localhost:xxxx,然后apache绑定到外部ip的80端口,并通过反射代理对iis站点进行代理

Todd Pointer | 园豆:379 (菜鸟二级) | 2013-11-16 13:51
0

现在不是流行linux+apache+asp.net(xsp是linux下的asp.net框架)+mysql

秋壶冰月 | 园豆:5692 (大侠五级) | 2013-11-16 14:31
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册