首页新闻找找看学习计划

VS2012 的NET3.5框架使用MsChart控件

0
悬赏园豆:10 [待解决问题]

由于项目要求,VS2012需要使用NET3.5框架,但发现在VS2012只有.NET4.0框架的MsChart控件,我在微软官网下载了.NET3.5的MsChart控件安装包,但安装完了还是没显示,手工添加dll,但还是显示4.0版本的,有没有什么办法??(WIN7电脑)

kuroro的主页 kuroro | 初学一级 | 园豆:157
提问于:2013-11-21 19:09
< >
分享
所有回答(2)
0

安装的时候,有没有提示,会影响 framework 3.5 sp1啊?如果没有 重新安装一下,我这里有一个,需要的话,说一下邮箱,发给你

秋壶冰月 | 园豆:5450 (大侠五级) | 2013-11-21 19:33

有提示,说更新会影响framework 3.5 sp1,那我该怎么办呢?

支持(0) 反对(0) kuroro | 园豆:157 (初学一级) | 2013-11-21 20:33

@kuroro: 我刚才用万能解压,提取文件,提示要注册 “到C:\WINDOWS\system32目录下。命令行运行regsvr32 mschrt20.ocx注册控件”

搜了一下,说“

微软的一个叫ActiveX Kill Bits的更新搞的。我把注册表项HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\ActiveX Compatibility下mschart相关的项去掉就好使了”

这个mschart,我不怎么熟,以前安装是因为,项目要运行,才安装的,后来,我们用FusionCharts,只要有flash,就能显示图表

支持(0) 反对(0) 秋壶冰月 | 园豆:5450 (大侠五级) | 2013-11-21 21:32
0

跟你遇到同样的问题,我先装了官网的Exe 后  ,直接拖dll到工具箱,就有了。

dll 路径   C:\Program Files (x86)\Microsoft Chart Controls\Assemblies   我是web  用的第二个。

BetterCoder | 园豆:109 (初学一级) | 2017-10-18 19:59

你好,我也遇到了类似的问题,不过用的是VS 2017版,而项目要用3.5框架,4.0框架有chart的控件,可是3.5的就没有,大神有没有方法解决呀

支持(0) 反对(0) Tracy-crocodile | 园豆:200 (初学一级) | 2019-07-15 21:37
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册