首页 新闻 搜索 专区 学院

当tomcat 5.5.20遇上j2ee 6

0
悬赏园豆:5 [已解决问题] 解决于 2015-12-21 15:57

今天打算把我测试好的j2ee 6工程放到虚拟主机上,发现访问不了servlet,老是报404错误,但是我的web.xml是没问题的,是不是版本问题?如果是,该怎么解决?谢谢

kebin00的主页 kebin00 | 初学一级 | 园豆:196
提问于:2013-12-13 17:20
< >
分享
最佳答案
1

你的jdk选择1.6版本以上的应该可以的啊

收获园豆:5
bitbug | 菜鸟二级 |园豆:470 | 2013-12-16 10:10
其他回答(3)
0

别用 tomcat 了,上 WebSphere,有问题就给 IBM 打电话。

Launcher | 园豆:45045 (高人七级) | 2013-12-13 17:23
1

tomcat5系列支持JDK1.4及以上,JDK版本肯定是没有问题的。你排查一下,肯定是其他原因,比如你tomcat的context路径不是你访问的路径、大小写也有区别的、或者就是tomcat服务没启动起来,原因太多了。

孟衡 | 园豆:228 (菜鸟二级) | 2013-12-28 17:52

已经确认是因为我弄了个类,里面有一块static块,我在里面试图加载一个外部文件properties里面的信息,到时报了无法找到此类的错误,但是为什么不行我还是不知道,反正去掉加载外部文件的代码就可以了

支持(0) 反对(0) kebin00 | 园豆:196 (初学一级) | 2013-12-30 22:09
1

之前有遇到tomcat 7.32以下的版本不支持@Web*的标注 不知道你是不是这问题 

菜鸟老了 | 园豆:145 (初学一级) | 2014-01-28 08:50
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册