首页 新闻 搜索 专区 学院

急!jquery1.9游览器兼容性

0
悬赏园豆:50 [待解决问题]

上面分配了个任务,无从下手,找出哪些jquery哪些方法或对象不支持以下游览器

 
IE 8 9 10 ,chrome safari  firefox 只要对其中一种游览器的不支持,都找出来。
 
头痛的问题,大伙有没有类似的文档说明或一些其它帮助,请求帮助,谢谢。
gaoxingstyle的主页 gaoxingstyle | 初学一级 | 园豆:152
提问于:2013-12-17 14:47
< >
分享
所有回答(5)
0

这个你还是找jquery的官方文档吧,可能会对特别的方法做出注释,但是回过来想如果jquery还存在不兼容的方法应该是不会把方法提供出来,当然不针对低版本的浏览器 ,

Zery | 园豆:6139 (大侠五级) | 2013-12-17 15:11
0

我建议你用jq1.6

因为你不仅仅要支持浏览器 还要支持 验证组件(jquery.validate.js) 还要支持jquery ui(jquery-ui.js)

取3者的交集

唯有jq1.6

小眼睛老鼠 | 园豆:2774 (老鸟四级) | 2013-12-17 15:17

其中jquery.validate.js 好像还只能用1.9版本

因为这东西高版本的不支持ie8

支持(0) 反对(0) 小眼睛老鼠 | 园豆:2774 (老鸟四级) | 2013-12-17 15:18

jquery的 扩展库 例如ui validate

对核心的 jquery 支持的版本都不高

支持(0) 反对(0) 小眼睛老鼠 | 园豆:2774 (老鸟四级) | 2013-12-17 15:19
0

jquery有没有支持文档,就是把所有方法的支持情况罗列出来的那种。

angelshelter | 园豆:9676 (大侠五级) | 2013-12-17 17:26
0

除了firefox 对jquery支持比较低,其他的基本上大部分测试过没有很大问题

拾梦小侠ด้้้ | 园豆:752 (小虾三级) | 2013-12-17 20:00
0

实在不行就对特定的浏览器逐个测试

Albert Fei | 园豆:2102 (老鸟四级) | 2013-12-20 17:05
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册