首页 新闻 搜索 专区 学院

asp.net mvc4 性能问题

0
悬赏园豆:10 [已解决问题] 解决于 2014-03-16 23:29

我在本地创建了一个asp.net mvc4的站点,然后发布到IIS7上。我先用chrome浏览器打开,运行。然后我在用IE10代开这个站点,浏览器一直处于加载中,很长时间打不开,不清楚是为什么?

哪位高人能够解答一下吗?

难道IIS设置了只能是默认浏览器打开?非常奇怪,困扰我几天..

问题补充:

没有数据库啊,就是建立了一个demo的站点,脚本没有错误,页面根本就没呈现一直白屏,并且明显感觉机器风扇明显加快CPU明显上升。

很奇怪,担心是IIS问题吗?可是又不知道如何排查问题。

这里再补充一下,由于我本机的默认浏览器是chrome,所以我的IIS浏览的时候默认用chrome打开了,然后我又用IE10打开打开一个新的窗口,一直处于等待响应,很长时间以后页面显示: Server Too Busy。

感觉就好像是,Chrome浏览器正在访问这个站点,其他浏览器不能再访问了,这台奇怪了, 当然这是偶尔,有时候就没有问题...

shen110的主页 shen110 | 初学一级 | 园豆:158
提问于:2013-12-21 01:38
< >
分享
最佳答案
0

好诡异...在chrome上是好的?

收获园豆:2
鳳梨酥 | 菜鸟二级 |园豆:287 | 2013-12-21 14:21
其他回答(7)
0

不能够吧,能说详细点儿吗

谦行 | 园豆:473 (菜鸟二级) | 2013-12-21 08:36
0

看一下是不是加载出现了脚本错误呢?

收获园豆:2
平常心队长 | 园豆:1113 (小虾三级) | 2013-12-21 08:56
0

第一次打开的话,是不是要创建数据库吧

魔多 | 园豆:1031 (小虾三级) | 2013-12-21 09:57
0

我遇到的问题是MVC4项目在IIS7上面,运行起来没有加载母版页的js/cs文件.不知道你遇到没有?

收获园豆:2
清歌水寒 | 园豆:96 (初学一级) | 2013-12-24 13:00

我到没有遇到这个问题,请问你的js和css文件是怎么导入的?使用Optimization的Bundle吗?

支持(0) 反对(0) shen110 | 园豆:158 (初学一级) | 2013-12-24 22:49

@shen110: 就是在母版页: <script src="@Url.Content("~/Scripts/jquery-1.8.2.min.js")"></script>这样引入.我的网站首页是index.cshtml.在IIS上面运行的时候,打开index页面,没有加载母版页,本地vs12自带的IIS express和win8/2012 IIS8正常运行

支持(0) 反对(0) 清歌水寒 | 园豆:96 (初学一级) | 2013-12-25 08:56

@清歌水寒: 个人觉得,首先你的IIS7是否把所有功能都开启了,然后再检查你的应用程序池,最后看看是否有什么地方你配置了静态文件劫持,比如route配置的时候是否忽略.js,.axd,.css等类似文件。

我本地没有出现过类似的问题。

支持(0) 反对(0) shen110 | 园豆:158 (初学一级) | 2013-12-25 17:55
0

加上效果图,再写详细一点儿。

aehyok | 园豆:1012 (小虾三级) | 2013-12-25 01:25
0

不如把你的DEMO页发出来,让别人本地运行一下啊,而且你这样描述。。最好截个Chrome和IE下的图进行对比看下,别人才好给意见。。

哎,简直是浪费沟通成本啊!!!!!

收获园豆:2
最佳损友。 | 园豆:103 (初学一级) | 2014-01-13 11:35

悲剧的是我都没有做任何东西,就用vs2012内置的Asp.net MVC4的demo站点创建出来,然后运行就行了。

更悲剧的这个问题有时候能呈现,有时候不能呈现。个人感觉是IIS的问题。迷惑当中。

支持(0) 反对(0) shen110 | 园豆:158 (初学一级) | 2014-01-13 22:25
0

在web.config配置文件里,可能是请求的字节数太小了,尝试把请求的的字节数改大点。

收获园豆:2
yunhai2014 | 园豆:221 (菜鸟二级) | 2014-02-11 10:40
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册