首页 新闻 搜索 专区 学院

VS2010安装了mvc4后,创建mvc4项目报错

0
悬赏园豆:50 [已解决问题] 解决于 2014-01-06 16:18

我是照网上的步骤先装vs2010 sp1补丁,再装mvc4,都没有报错,但是创建项目却报错了

一开始是报这个错

重新下载安装nuget之后又报下面的错

系统是XP的,不知道大牛们有没有遇到这种问题。

kyo66691的主页 kyo66691 | 初学一级 | 园豆:167
提问于:2014-01-03 17:08
< >
分享
最佳答案
1

大牛们都用 Win7,一次安装成功。

收获园豆:50
Launcher | 高人七级 |园豆:45045 | 2014-01-03 17:10

我也想用win7,奈何公司电脑全部都是装的xp

kyo66691 | 园豆:167 (初学一级) | 2014-01-03 17:12

@kyo66691: 你最开始的 MVC4 是怎么安装的?

Launcher | 园豆:45045 (高人七级) | 2014-01-03 17:17

@Launcher: 照网上的步骤,先装的vs2010 sp1补丁,再装的MVC4

kyo66691 | 园豆:167 (初学一级) | 2014-01-03 17:21

@kyo66691: 我想知道的是,你的 MVC4 安装包从哪儿来的?

Launcher | 园豆:45045 (高人七级) | 2014-01-03 17:28

@Launcher: 从CSDN上下载的,http://download.csdn.net/detail/caozhy/3619212#comment,看评论还不错

kyo66691 | 园豆:167 (初学一级) | 2014-01-03 17:32
Launcher | 园豆:45045 (高人七级) | 2014-01-03 17:36

@kyo66691: 公司的电脑,也可以用装win7啊?再说开发用win7和win8都一样,我以前公司的用win8,也没法人管,项目真正运行在服务器上,我们的机器,就是开发用的,开发实在不建议用xp,xp安装iis,都比较蛋疼!

秋壶冰月 | 园豆:5692 (大侠五级) | 2014-01-03 22:40
其他回答(4)
0

按照这个流程走,保证你能装成功。

落叶飞逝的恋 | 园豆:118 (初学一级) | 2014-01-03 17:39

你这是MVC3,我已经装过了,可以用,现在是装了MVC4新建MVC4项目时报错

支持(0) 反对(0) kyo66691 | 园豆:167 (初学一级) | 2014-01-06 09:56
0

 把VS2010修复一次(双击安装文件选择修复) 然后安装sp1补丁,再到微软官方下载MVC4的安装包。

Zery | 园豆:6139 (大侠五级) | 2014-01-03 18:03

我试试吧,再不行,只能说明xp上不能装MVC4了

支持(0) 反对(0) kyo66691 | 园豆:167 (初学一级) | 2014-01-06 10:02

还是不行,不折腾了,浪费时间。

支持(0) 反对(0) kyo66691 | 园豆:167 (初学一级) | 2014-01-06 16:16
0

哈哈,赶紧上WIN8吧,XP可能不支持MVC4了

男人要爽 | 园豆:15 (初学一级) | 2014-01-04 17:50
0

兄弟,你的问题解决了吗,因为你少了nuget包没安装,到官网下载安装后错误解决:这个是VS2010版本的,nuget 版本不一样,一样不支持创建MVC4,所以版本也要选择对

https://visualstudiogallery.msdn.microsoft.com/27077b70-9dad-4c64-adcf-c7cf6bc9970c

其他版本到官网下载

https://dist.nuget.org/index.html

 

小K | 园豆:202 (菜鸟二级) | 2016-03-11 23:28
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册