首页新闻找找看学习计划

超神的来帮我解决下吧,困扰的我想砸电脑了

0
悬赏园豆:20 [已解决问题] 解决于 2014-12-02 17:06

同样的源码在别人机子上是可以跑起来的,在我机子上就不行

 

 

Google-WL的主页 Google-WL | 初学一级 | 园豆:103
提问于:2014-09-04 11:29
< >
分享
最佳答案
0

除了把电脑砸了,好象也没有太多其他方案了。当然,把电脑送给贫困学生也是一个可行的方案。

收获园豆:20
爱编程的大叔 | 高人七级 |园豆:29862 | 2014-09-04 11:32

给点希望好吗

Google-WL | 园豆:103 (初学一级) | 2014-09-04 12:18
其他回答(12)
0

重新编译一下项目试试

dudu | 园豆:39111 (高人七级) | 2014-09-04 11:36

编译过无数遍了,哎

支持(0) 反对(0) Google-WL | 园豆:103 (初学一级) | 2014-09-04 12:15

@Google-WL: 建议配置一个IIS站点跑一下试试

支持(0) 反对(0) dudu | 园豆:39111 (高人七级) | 2014-09-04 12:55
0

更换浏览器,或者是浏览器版本过高。

gcking33 | 园豆:202 (菜鸟二级) | 2014-09-04 11:39

ie也有问题的吗?

支持(0) 反对(0) Google-WL | 园豆:103 (初学一级) | 2014-09-04 12:15
0

环境设置问题,MVC的话去百度下部署过程

吴瑞祥 | 园豆:28729 (高人七级) | 2014-09-04 11:39

我也是这么想的,可就是不知道哪里有问题,能否详细点?不是mvc是webservice

支持(0) 反对(0) Google-WL | 园豆:103 (初学一级) | 2014-09-04 12:16
0

错误信息是说你的Global.asax文件对应的Global.asax.cs文件没对应好,检查下文件是否匹配,派生(继承)的类是否匹配。

519740105 | 园豆:5810 (大侠五级) | 2014-09-04 11:41

好像是没有问题的

支持(0) 反对(0) Google-WL | 园豆:103 (初学一级) | 2014-09-04 12:18

@Google-WL: 确实看起来是没问题的。但你的错误信息却指的是这个。

你可以:把代码复制出去,然后删除global后重新创建一个看?

支持(0) 反对(0) 519740105 | 园豆:5810 (大侠五级) | 2014-09-04 13:34

@519740105: 我试过了,还是不行,会不会是环境的问题啊?我的是vs2005,让后打的sp1的补丁

支持(0) 反对(0) Google-WL | 园豆:103 (初学一级) | 2014-09-04 13:57

@Google-WL: 别人的机器用的VS是什么版本?是否一致的.NET环境?如果上面我说的问题真能的不存在,那可能的就是你的global这个类没有编译成功了。

支持(0) 反对(0) 519740105 | 园豆:5810 (大侠五级) | 2014-09-04 14:19
0
<%@ Application Language="C#" %>

其他的去掉呢?
天真浪浪 | 园豆:950 (小虾三级) | 2014-09-04 12:28

还是报同样的错误,还有别的招吗?

支持(0) 反对(0) Google-WL | 园豆:103 (初学一级) | 2014-09-04 13:52
0

先Clean一次,再来~

幻天芒 | 园豆:36522 (高人七级) | 2014-09-04 12:55

我已经clean过无数次了,还是不行。还有别的招吗?

支持(0) 反对(0) Google-WL | 园豆:103 (初学一级) | 2014-09-04 13:50

@Google-WL: 从错误来看,应该是页面文件和程序集不对应引起的呀。。。如果确认程序集没错,删掉怎么bin目录看看。

支持(0) 反对(0) 幻天芒 | 园豆:36522 (高人七级) | 2014-09-04 14:04

@幻天芒: 删掉了重新编译运行的话还是这个错,还有别的建议吗?

支持(0) 反对(0) Google-WL | 园豆:103 (初学一级) | 2014-09-04 14:16

@Google-WL: 发现你截图中的项目,有编译错误,这样的话,程序集不一定能生成的。

支持(0) 反对(0) 幻天芒 | 园豆:36522 (高人七级) | 2014-09-04 17:13
0

查看一下所有的 引用,是否正常,我个人以前装的插件和别人的插件版本不一样,编译成功运行报错

风醉 | 园豆:1197 (小虾三级) | 2014-09-04 13:54

引用都是没有问题的,请问还要检查什么?

支持(0) 反对(0) Google-WL | 园豆:103 (初学一级) | 2014-09-04 13:59

@Google-WL: 我看你那截图底下不是有40多个错误嘛...

支持(0) 反对(0) 风醉 | 园豆:1197 (小虾三级) | 2014-09-04 14:04

@Google-WL: 还有你的浏览器是360保护的,360会自动屏蔽一些脚本,这个原因虽然很小,但我建议把火狐设置成默认的调试浏览器,具体情况不知道,建议排除所有错误和一些客观原因,对比两台电脑的版本插件,还有引用的项目单独运行情况

支持(0) 反对(0) 风醉 | 园豆:1197 (小虾三级) | 2014-09-04 14:07

@许爱生活: 我已经关闭了360依然是哪个错,坑爹啊,快疯了

支持(0) 反对(0) Google-WL | 园豆:103 (初学一级) | 2014-09-04 14:16

@Google-WL: 你截图中你的项目提示的错误是不存在的还是什么情况?

支持(0) 反对(0) 风醉 | 园豆:1197 (小虾三级) | 2014-09-04 14:28

@许爱生活: 现在已经没有错了,还是报刚刚那个错误.

支持(0) 反对(0) Google-WL | 园豆:103 (初学一级) | 2014-09-04 14:35
0

这种一般是你配置的不对,可能跟文件夹权限,IIS权限,项目的配置文件等有关,和代码的关系不是很大

最长的路漫漫 | 园豆:252 (菜鸟二级) | 2014-09-04 18:19
0

,不知道什么原因造成的。

贫民窟大侠 | 园豆:4270 (老鸟四级) | 2014-09-10 17:53
0

 检查一下发布项目的文件权限先

Halower | 园豆:1723 (小虾三级) | 2014-09-14 20:06
0

难道是.Net FrameWork 版本太低了

大志若愚 | 园豆:1062 (小虾三级) | 2014-09-28 10:23
0

你的vs 2005版本太低了,bin文件里多检查下,然后看一下你的dll是不是最新的,然后再检查下web.config,

amityat | 园豆:476 (菜鸟二级) | 2014-10-10 14:34
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册