首页 新闻 搜索 专区 学院

Asp.net vNext 怎么部署到IIS8.0 上面?

0
悬赏园豆:80 [待解决问题]

部署上去,访问就报错了! 是不是要下一个最新的.net framework4.52

胡一飘的主页 胡一飘 | 初学一级 | 园豆:66
提问于:2014-10-06 16:55
< >
分享
所有回答(5)
0

操作系统要win2012R2

freewzx2005 | 园豆:8 (初学一级) | 2014-10-06 18:04
0

Windows

  • Windows 7 or Windows Server 2008 R2.
  • .NET 4.5.1 for hosting in IIS

然后要装KVM和KRE.之后还是看文档吧

https://github.com/aspnet/home

https://github.com/aspnet/Home/wiki

Cherbim | 园豆:323 (菜鸟二级) | 2014-10-06 23:45
0

看了上面两个回答,应该能帮助你吧?

他们说的这些,比如要win2012r2、比如要.net 4.5.1等,我不明白(没研究过),但是,他们的回答有冲突部分,一楼说要2012r2,二楼说要win7或2008r2。

就你这个问题而言,字面意思很明白,KRE没安装或者KRE的版本配置不正确,所以,你可以:

1、确认KRE是否正确安装了

2、如果KRE已经正确安装了,检查下提示信息里的版本配置

3、如果以上都做到了,再核对二楼给你的方案与建议。

519740105 | 园豆:5810 (大侠五级) | 2014-10-07 08:04
0

当然要.net 4.5.2+了,另外你KRE的dll少部署没?

wdwwtzy | 园豆:28 (初学一级) | 2014-10-07 14:27
0

vnext目前似乎要部署到IIS上64位是不行的

draculav | 园豆:734 (小虾三级) | 2014-10-09 13:12

解决了 我一上午的问题啊!

支持(0) 反对(0) eastday | 园豆:217 (菜鸟二级) | 2014-12-18 11:32
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册