首页 新闻 搜索 专区 学院

在JS框架Dojo中使用dojo.require方法是会报出异常,如下,应该怎么做还是我用错了

0
[已关闭问题] 关闭于 2014-11-06 09:47

源代码:

dojo.require("dojo.widget.ContentPane", function(){console.log("require success");});

控制台的错误提示:

主线程中同步的 XMLHttpRequest 已不推荐使用,因其对终端用户的用户体验存在负面影响

北在北方的主页 北在北方 | 初学一级 | 园豆:182
提问于:2014-11-02 19:59
< >
分享
所有回答(1)
0

我也碰到这个问题,不知道楼主怎么解决的?

countryer | 园豆:154 (初学一级) | 2015-10-11 17:26

dojo.require是旧式的模块加载api,可以使用新的require,其次在dojoconfig中设置async为false来使用异步加载模块,试试看。

支持(0) 反对(0) 北在北方 | 园豆:182 (初学一级) | 2015-10-11 23:36

@北在北方: 谢谢,我是改成异步后,没有使用新的require,改了之后就可以了

支持(0) 反对(0) countryer | 园豆:154 (初学一级) | 2015-10-13 14:15
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册