首页 新闻 搜索 专区 学院

[javascript] : window.require = {}在IE下有什么bug?

0
[已解决问题] 解决于 2015-06-16 22:59

window.require = {}在IE下有什么bug?

在API中提到Node: 不要再IE下使用window.require = {},这会导致不正常的表现,为什么呢?如下:

在requirejs.org官网的API中:(http://requirejs.org/docs/api.html#config),注意:

问题补充:

在underscore.js官网的annotated source code 中也提到另外1个IE11的bug,但是我本机IE11就表现的是正常的,图片为:请问是为什么?

本机IE11,

Object.prototype.toString.call(function(){})   -> [object Function]

typeof /./  -> object

Thirty的主页 Thirty | 菜鸟二级 | 园豆:252
提问于:2014-11-06 16:52
< >
分享
最佳答案
0

不明所以,typeof /./ 根据jquery源码的issue,好想是早期的chrome内核会把它解释成function

Thirty | 菜鸟二级 |园豆:252 | 2015-06-16 22:58
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册