首页新闻找找看学习计划

前端开发有什么框架式支持IE8及以上的呢

1
悬赏园豆:50 [已解决问题] 解决于 2014-11-16 16:19

  项目启动中需要用到一个前端的框架,找到了charisma,界面看着不错,谷歌火狐兼容性都还行,可是到了IE哪儿感觉节操一切都没了,想着都头痛,各位有没有什么框架或者方法推荐下的...这事找了好久都没有眉目

sevennight的主页 sevennight | 初学一级 | 园豆:114
提问于:2014-11-06 18:03
< >
分享
最佳答案
0

国内有个阿瓦隆,你在园子里找.

ko,wijmo支持到ie6,

收获园豆:30
吴瑞祥 | 高人七级 |园豆:28729 | 2014-11-06 18:07
其他回答(2)
0

你需要哪种类型的前端框架?easyUI,findUI,ligerUI,dwz,extjs这种?还是bootstrap,foundation这种?

收获园豆:10
幻天芒 | 园豆:36522 (高人七级) | 2014-11-07 08:53

我找的charisma,就是基于bootstrap开发的,bootstrap3开始就完全不支持IE678了,只要保持IE8能支持的框架都行

支持(0) 反对(0) sevennight | 园豆:114 (初学一级) | 2014-11-07 16:48

@sevennight: IE6和7确实没办法,在IE8加上特定js还是可以跑起来的。你可以看看bootcss这个网站。

支持(0) 反对(0) 幻天芒 | 园豆:36522 (高人七级) | 2014-11-07 17:32
0

前端框架,bootstrap这种 有很多模版,这种灵活度比较高,样子很漂亮。缺点是控件比较少。

js框架这种,灵活度相对弱点,控件多,适合快速开发使用,美工一般。

收获园豆:10
xiaocong_soft | 园豆:556 (小虾三级) | 2014-11-07 11:30
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册