首页新闻找找看学习计划

求教前辈:tarball源码安装ruby python等如何解决类似ruby-devel python-devel依赖库的问题

0
悬赏园豆:10 [已关闭问题] 关闭于 2014-12-09 23:12

大家好:

    如题。本人正在CentOS6中搭建vim-as-nodejs-ide 环境,而https://github.com/Valloric/YouCompleteMe/wiki/Building-Vim-from-source

页面给出的如下命令:

sudo yum install -y ruby ruby-devel lua lua-devel luajit \
    luajit-devel ctags mercurial python python-devel \
    python3 python3-devel tcl-devel \
    perl perl-devel perl-ExtUtils-ParseXS \
    perl-ExtUtils-XSpp perl-ExtUtils-CBuilder \
    perl-ExtUtils-Embed

安装的ruby和python版本都感觉很旧,所有我选择编译源码的方式安装,可是不知道类似“XXX-devel”这种库文件依赖的问题该怎么解决。我在http://stackoverflow.com/questions/7880454/python-executable-not-finding-libpython-shared-library 页面找到如下命令(没完全明白该命令):

./configure --enable-shared \
            --prefix=/usr/local \
            LDFLAGS="-Wl,--rpath=/usr/local/lib"

不知道这是否是解决“XXX-devel”这类问题的较通用的做法,如果是,ruby是否可以用同样的方式呢?因为缺乏相关的理论知识和实践经验,所以望请高人能提供一下这类问题的解决方法。

不甚感谢!

niaocai的主页 niaocai | 菜鸟二级 | 园豆:202
提问于:2014-12-09 12:35
< >
分享
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册