首页新闻找找看学习计划

EasyUi在不同浏览器版本上头疼的兼容问题

0
悬赏园豆:30 [已关闭问题] 关闭于 2015-06-15 16:06

在用EasyUi时,有时候页面呈现空白页,所用到的控件不能正常显示。目前不能显示的控件有easyui-tab,easyui-validatebox(上传附件的英文好像写错了但有用到),其它的像easyui-datagrid都可以正常显示,详请见如下截图:

实际上是有内容和数据返回的,却显示空白页。

麻煩知道的朋友告之下,不勝感激!

问题补充:

有部分网友表示浏览器不兼容的问题,我用的是 jQuery1.8.0,EasyUI1.3.2,在ie8兼容模式下ok,ie11就显示空白页。缓存也清理了。有知道的么

小熊QQ糖的主页 小熊QQ糖 | 初学一级 | 园豆:152
提问于:2015-01-07 17:04
< >
分享
所有回答(2)
0

顺着闪存来的。不会~~

+小马哥++ | 园豆:906 (小虾三级) | 2015-01-07 17:17

想着应该是缓存的问题,然后easyui+jQuery的版本搭配,一些浏览器不兼容,也是头疼

支持(0) 反对(0) 小熊QQ糖 | 园豆:152 (初学一级) | 2015-01-08 11:00
0

其实你还会发现进制转换的问题,在IE9及以下,对于整型的转换都是为八进制,只有在IE9以上的浏览器才会是10进制的转换(目前只发现easyUI版本为1.4.3会出现这个现象)

日耳曼战车 | 园豆:202 (菜鸟二级) | 2016-03-30 10:50
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册