首页新闻找找看学习计划

请问支持MVC3的虚拟主机,能否部署基于MVC4的程序

0
悬赏园豆:10 [待解决问题]

把MVC4相关的Dll都放到bin目录下,好像还是不行,请问有没有可能让只支持MVC3的虚拟主机来支持MVC4?

另外,虚拟主机上的MVC3版本是3.0.0.0,而开发时是基于3.0.0.1的,这个需要把哪些dll放到bin目录?只放了System.Web.Mvc.dll还是不行。

问题补充:

用的是阿里云万网的虚拟主机。

支持.net Framework4.0+MVC3

youyi000的主页 youyi000 | 菜鸟二级 | 园豆:205
提问于:2015-02-09 10:14
< >
分享
所有回答(5)
0

是不是你的.net Framework版本不支持啊,你装上.net Framework 4.0试试!

酷小孩 | 园豆:243 (菜鸟二级) | 2015-02-09 21:34

是.net Framework4.0。

支持(0) 反对(0) youyi000 | 园豆:205 (菜鸟二级) | 2015-02-10 09:38
0

如果虚拟主机有.net framework 4.0的话应该就可以了。你把详细错误贴出来看看。

xiaocong_soft | 园豆:556 (小虾三级) | 2015-02-10 09:27

虚拟主机上是4.0,放上MVC3的程序是可以正常运行的,换成MVC4的,直接路由都不起作用了,就是提示找不到文件,因为路由的路径不存在。

支持(0) 反对(0) youyi000 | 园豆:205 (菜鸟二级) | 2015-02-10 09:39

@youyi000: 是不是iis配置对吗?.net framework 版本选择了吗?是不是集成模式?是否添加mvc的程序映射?

支持(0) 反对(0) xiaocong_soft | 园豆:556 (小虾三级) | 2015-02-10 09:48

@xiaocong_soft: 不是这些问题,而且是虚拟主机,不能直接配置IIS,确认是4.0经典模式,MVC3是可以运行的。

支持(0) 反对(0) youyi000 | 园豆:205 (菜鸟二级) | 2015-02-10 09:51
0

只要.net 版本正确就可以了,就算虚拟机上没有安装mvc,你也可以在将mvc相关的dll拷贝到项目里运行。

virtual1988 | 园豆:252 (菜鸟二级) | 2015-04-13 09:54
0

怎么解决的。

LoveStars | 园豆:204 (菜鸟二级) | 2015-12-01 18:40

没有解决。。。

支持(0) 反对(0) youyi000 | 园豆:205 (菜鸟二级) | 2015-12-02 16:46

@youyi000: 在解决方案新建空MVC项目,将一些dll文件上传就可以了。

System.Web.Razor.dll

System.Web.WebPages.dll

System.Web.WebPages.Deployment.dll

......

支持(0) 反对(0) LoveStars | 园豆:204 (菜鸟二级) | 2015-12-10 10:52

@hito: 就放这三个就可以?还是还需要一些,我把MVC相关的放上去是不行的。

支持(0) 反对(0) youyi000 | 园豆:205 (菜鸟二级) | 2015-12-10 13:10

@youyi000: 现在也遇到同样问题了。兄台如何解决?后来去别的地方买空间?

支持(0) 反对(0) 赏音师 | 园豆:221 (菜鸟二级) | 2016-03-24 11:04
0

现在也遇到同样问题了。兄台如何解决?后来去别的地方买空间?

赏音师 | 园豆:221 (菜鸟二级) | 2016-03-24 11:04

后来就没用MVC4

支持(0) 反对(0) youyi000 | 园豆:205 (菜鸟二级) | 2016-03-24 11:30

@youyi000: ...搜索到另一家jt专做.net云主机的,又不知道怎样。。。

支持(0) 反对(0) 赏音师 | 园豆:221 (菜鸟二级) | 2016-03-24 11:31
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册