首页 新闻 搜索 专区 学院

python2.7安装sklearn报错:ImportError: DLL load failed

0
悬赏园豆:50 [待解决问题]
import sklearn
报错:
Traceback (most recent call last):
File "<pyshell#3>", line 1, in <module>
import sklearn
File "D:\Python27\lib\site-packages\scikit_learn-0.15.2-py2.7-win-amd64.egg\sklearn\__init__.py", line 38, in <module>
from .base import clone
File "D:\Python27\lib\site-packages\scikit_learn-0.15.2-py2.7-win-amd64.egg\sklearn\base.py", line 10, in <module>
from scipy import sparse
File "D:\Python27\lib\site-packages\scipy\sparse\__init__.py", line 182, in <module>
from .csr import *
File "D:\Python27\lib\site-packages\scipy\sparse\csr.py", line 15, in <module>
from .sparsetools import csr_tocsc, csr_tobsr, csr_count_blocks, \
File "D:\Python27\lib\site-packages\scipy\sparse\sparsetools\__init__.py", line 5, in <module>
from .csr import *
File "D:\Python27\lib\site-packages\scipy\sparse\sparsetools\csr.py", line 26, in <module>
_csr = swig_import_helper()
File "D:\Python27\lib\site-packages\scipy\sparse\sparsetools\csr.py", line 22, in swig_import_helper
_mod = imp.load_module('_csr', fp, pathname, description)
ImportError: DLL load failed: %1 不是有效的 Win32 应用程序。

用的python2.7.9,我已经安装了numpy1.9.1,scipy0.12.0,sklearn0.15.1,这些都是支持64位系统的,遇到这个问题我该怎么办

豆子不多,请不吝赐教啊
啤酒与炸鸡的主页 啤酒与炸鸡 | 初学一级 | 园豆:152
提问于:2015-03-08 01:55
< >
分享
所有回答(1)
0

解决了吗?我也遇到这个问题,搞了好几天,还没解决。你解决了的话,分享一下咯。

C/C++攻城狮 | 园豆:187 (初学一级) | 2016-04-21 13:51
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册