首页新闻找找看学习计划

请问Android是怎么做到高版本程序在低版本系统上运行的?

0
悬赏园豆:10 [待解决问题]

创建项目时选择的SDK如下图所示:

 

这样编译出来的APK能在Android4.4.2的系统上运行,也能在2.3的系统上运行。。

 

我觉得有点奇怪,2.3的系统怎么能向上兼容到4.4的程序呢?

难道2.3的系统里会有4.4的API吗?不可能啊。。

 

向下兼容到是好理解,4.4的系统保留2.3的API,就可以运行2.3的程序了。

可是向上兼容,有点不明白,所以想知道它是怎么做到 能向上兼容的?。。谢谢解答。

 

hexllo的主页 hexllo | 菜鸟二级 | 园豆:405
提问于:2015-03-19 09:10
< >
分享
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册