首页 新闻 搜索 专区 学院

同一机器上能同时安装.net framework3.5和.net framework2.0吗

0
悬赏园豆:5 [已解决问题] 解决于 2009-06-17 09:36

同一台机器为什么上能同时安装.net framework2.0和.net framework1.0,而不能同时安装.net framework3.5与.net framework2.0呢? vs2005下能用.net framework3.0不

eastcowboy的主页 eastcowboy | 初学一级 | 园豆:185
提问于:2009-05-29 20:10
< >
分享
最佳答案
0

装了3.5以后就能使用2.0的,因此有了3.5也就不需要2.0了,这是因为3.5和2.0的CLR没人变化,所以会把2.0给覆盖了吧

2.0和1.0之间的CLR是有升级的,因此要同时保留

VS2005能使用3.0

Gray Zhang | 专家六级 |园豆:17610 | 2009-05-29 20:37
其他回答(8)
0

呵呵,这个是可以的,不过一般先装上2.0再装上3.5,呵呵,可以的,在VS里新建项目的时候可以选择的是2.0还是3.0或是3.5都可以的,当然是在VS2008里面,呵呵给你看个图吧,

 

苏飞 | 园豆:2024 (老鸟四级) | 2009-05-29 20:52
0

你每一个版本都可以安装,默认在c盘Windows里,有点占资源就是!

Humsil Dai | 园豆:130 (初学一级) | 2009-05-30 00:31
0

当然可以,到C:\WINDOWS\Microsoft.NET\Framework看看就知道了

cnhzlt | 园豆:399 (菜鸟二级) | 2009-05-30 11:32
0

怎么个不能同时安装呢?不过你得按顺序安装才行。

风海迷沙 | 园豆:4453 (老鸟四级) | 2009-05-30 12:14
0

可以的...

 我的c盘下就有2.0和3.0的目录...

原则上先装2.0,再装3.0

IamDavid | 园豆:205 (菜鸟二级) | 2009-05-30 13:09
0

当然可以,3.5的CLR并没有发生变化,还是使用的2.0的CLR。只是增加了一些程序集和功能。

不久就发布新的CLR,4.0

Tony Chi | 园豆:310 (菜鸟二级) | 2009-05-30 13:17
0

可以的! 我电脑上有2.0  3.0  3.5   4.0

綄羙,幷 卜羙 | 园豆:210 (菜鸟二级) | 2009-05-30 18:36
0

完美可以!

基本上可以这么说,MS从1.x开始一致可以安装到最新的MS Framework库

1.X 2.X 3.X 到目前的4.0

西越泽 | 园豆:10633 (专家六级) | 2009-06-01 00:17
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册