首页新闻找找看学习计划

关于Jquery和Jquery easyui冲突的问题!

0
悬赏园豆:40 [待解决问题]

<link rel="stylesheet" type="text/css" href="../jquery-easyui-1.4.2/themes/default/easyui.css">
<link rel="stylesheet" type="text/css" href="../jquery-easyui-1.4.2/themes/icon.css">
<link rel="stylesheet" type="text/css" href="../jquery-easyui-1.4.2/demo.css">
<script type="text/javascript" src="../jquery-easyui-1.4.2/jquery.min.js"></script>
<script type="text/javascript" src="../imgareaselect/scripts/jquery.min.js"></script>
<script type="text/javascript" src="../jquery-easyui-1.4.2/jquery.easyui.min.js"></script>
<script type="text/javascript" src="../jquery-easyui-1.4.2/locale/easyui-lang-zh_CN.js"></script>
<script src="../uploadPreview/uploadPreview.js" type="text/javascript"></script>
<script type="text/javascript" src="js/EditTeacher.js" charset="UTF-8"></script>
<script type="text/javascript" src="js/editTeacherPic.js" charset="UTF-8"></script>

<script type="text/javascript" src="../swfupload/swfupload.js"></script>
<script type="text/javascript" src="../imgareaselect/scripts/jquery.imgareaselect.pack.js"></script>
<link href="../css/style.css" rel="stylesheet" type="text/css"/>
<link href="../css/default.css" rel="stylesheet" type="text/css"/>
<link href="../imgareaselect/css/imgareaselect-default.css" rel="stylesheet" type="text/css"/>

中<script type="text/javascript" src="../jquery-easyui-1.4.2/jquery.min.js"></script>
<script type="text/javascript" src="../imgareaselect/scripts/jquery.min.js"></script>这两个冲突了。。。。有些效果出不来,怎么办啊???网上说的什么

noConflict()我不会用啊。。。

小太阳有白羊梦的主页 小太阳有白羊梦 | 初学一级 | 园豆:144
提问于:2015-06-04 20:04
< >
分享
所有回答(7)
0

那就选其中一个呗。

angelshelter | 园豆:9676 (大侠五级) | 2015-06-04 20:57

不行啊,我在做一个图片上传剪切功能,用的插件需要。。。其他的代码又需要另一个

支持(0) 反对(0) 小太阳有白羊梦 | 园豆:144 (初学一级) | 2015-06-04 20:59

@小太阳有白羊梦: 这两上是同一个文 件,是应该选一个就行,你留第一个吧,这样两个框架都能找到jquery

支持(0) 反对(0) angelshelter | 园豆:9676 (大侠五级) | 2015-06-06 16:38
0

你可以选择更高版本的jq

醉心 | 园豆:99 (初学一级) | 2015-06-04 23:30

我的一个jquery1.9.1一个jqueryui1.4.2,好像都是最高吧

支持(0) 反对(0) 小太阳有白羊梦 | 园豆:144 (初学一级) | 2015-06-05 00:18

@小太阳有白羊梦: 

别着急,你试下用下较低版本的jq,最好是1.4的那种

支持(0) 反对(0) 醉心 | 园豆:99 (初学一级) | 2015-06-05 08:58

@醉心: 好的呢,我试试看~~

支持(0) 反对(0) 小太阳有白羊梦 | 园豆:144 (初学一级) | 2015-06-09 20:24
0

这个冲突应该现在没有了吧? 我项目中也是这么用的, 但是前提是你得用最高版本的。

请叫我头头哥 | 园豆:9382 (大侠五级) | 2015-06-04 23:54

没有啊…还是有问题,可以运行,但是运行结果不是自己想要的,我的一个是jquery1.9.1,一个是jquery ui1.4.1,

支持(0) 反对(0) 小太阳有白羊梦 | 园豆:144 (初学一级) | 2015-06-05 00:16

应该一个是1.4.2

支持(0) 反对(0) 小太阳有白羊梦 | 园豆:144 (初学一级) | 2015-06-05 00:19

我弄了好久都弄不出,可以请教下吗~~

支持(0) 反对(0) 小太阳有白羊梦 | 园豆:144 (初学一级) | 2015-06-05 00:20

@小太阳有白羊梦: 你的jquery-easyui是最新版本, jquery是1.9.1,现在新版本好像都不太支持easyui了,  你下载一个Jquery1.7以下版本的试试。 另外, 以后要实现ui效果的话, 推荐使用jquery.UI或者bootstrap,  现在微软新建项目里都是这俩了。

支持(0) 反对(0) 请叫我头头哥 | 园豆:9382 (大侠五级) | 2015-06-05 09:19

@请叫我头头哥: 好的,谢谢,我试试看

支持(0) 反对(0) 小太阳有白羊梦 | 园豆:144 (初学一级) | 2015-06-09 20:24
0

换未压缩版本 把冲突地方找出来修改

nicky0227 | 园豆:1069 (小虾三级) | 2015-06-05 14:11
0

删一个

小眼睛老鼠 | 园豆:2774 (老鸟四级) | 2015-06-06 14:03
0

你这两个都是jQuery文件啊,其中一个应该是jquery-easyui自带的jQuery文件,你可以删其中掉一个试试,另外,要注意jQuery引用的位置啊

Kirlian | 园豆:208 (菜鸟二级) | 2015-06-24 17:19

我试过了,删掉一个它的界面就会混乱。删掉另一个的话就会出现上传头像后有阴影遗留,而且不能再次用这个功能,必须刷新后才能

支持(0) 反对(0) 小太阳有白羊梦 | 园豆:144 (初学一级) | 2015-06-26 10:43
0

换版本

我是糖糖 | 园豆:446 (菜鸟二级) | 2016-01-07 11:19
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册