首页 新闻 搜索 专区 学院

使用Devexpress 控件多版本冲突问题,急?

0
悬赏园豆:20 [已解决问题] 解决于 2009-06-01 09:47

  在项目中先是使用了以前的版本 Devepress 8.2,昨天下载安装了 Devexpress 9.1.3, 在同一项目中引用了9.1.3版本文件 ,在编译时出错,

错误 CS0433: 类型“DevExpress.Web.ASPxEditors.ASPxDateEdit”同时存在于“c:\Program Files\Developer Express .NET v8.2\Sources\DevExpress.DLL\DevExpress.Web.ASPxEditors.v8.2.dll”和“e:\网站项目\eHR\eHR\Inc\DevExpress.Web.ASPxEditors.v9.1.dll”中
c:\Program Files\Developer Express .NET v8.2\Sources\DevExpress.DLL\DevExpress.Web.ASPxEditors.v8.2.dll: (相关文件)
e:\网站项目\eHR\eHR\Inc\DevExpress.Web.ASPxEditors.v9.1.dll: (相关文件)

只要是使用了8.2版本中的命名空间就与9.1.3版本中冲突,初步怀疑是他们使用了同样的命名空间,但不知道现在如何解决?
高分求助?谢谢!

Luosen的主页 Luosen | 初学一级 | 园豆:175
提问于:2009-05-31 22:46
< >
分享
最佳答案
1

直接用DevExpress 自带的工具给项目升级一下就可以了。不影响原来项目的运行。

winzheng | 大侠五级 |园豆:8797 | 2009-06-01 09:03
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册