首页 新闻 搜索 专区 学院

服务器上的iis发布网站问题

0
悬赏园豆:15 [已解决问题] 解决于 2015-06-25 12:16

服务器上的iis只有v2.0没有v4.0,我现在有个4.0的网站放上去,那种方法更好些,是网站转2.0发布,还是在iis上装v4.0?

iis
问题补充:

还有 就是,如果服务器上安装v4.0 对原有的网站有影响吗?

 

如果网站转成v2.0,里面会报很多错,这个怎么改?

..00..的主页 ..00.. | 初学一级 | 园豆:49
提问于:2015-06-19 14:38
< >
分享
最佳答案
0

装 4.0,不会对原有的 2.0 的造成影响。

4.0 改 2.0 后,所有错误都可以改正确,但是有的错误可能需要你花更大力气修改,我指的是代码。

收获园豆:4
Launcher | 高人七级 |园豆:45045 | 2015-06-19 14:38

我要晕了,服务器太老了,只能转程序,不能再装v4.0。 这个程序转着好多报错。我不知道怎么改了。。。

..00.. | 园豆:49 (初学一级) | 2015-06-19 17:48

@..00..: 先在 VS 中将每个项目的目标框架修改为 .Net Framework 3.5 或者 .Net Framework 2.0(我为什么要这么说呢?因为 Asp.Net 2.0 这里的版本号不是同 .Net Framework 一一对应的。)。然后编译。

Launcher | 园豆:45045 (高人七级) | 2015-06-19 17:51
其他回答(8)
0

安装4.0不会原有网站有影响。

收获园豆:1
^上善若水^ | 园豆:227 (菜鸟二级) | 2015-06-19 14:54
0

你服务器上最好是装高版本的.net ,  不仅不会对原有的网站有影响, 而且安全性和性能都会有所提升。 

收获园豆:1
问天何必 | 园豆:3301 (老鸟四级) | 2015-06-19 15:28
0

没影响!

收获园豆:1
贫民窟大侠 | 园豆:4270 (老鸟四级) | 2015-06-19 15:57
0

只要服务器能装就装~没影响的~

收获园豆:1
NetRube | 园豆:277 (菜鸟二级) | 2015-06-19 16:52
0

如果可行,优先装4.0。并把其他2.0的网站,也用4.0跑。高版本只要稳定,一般是优于低版本。

收获园豆:4
幻天芒 | 园豆:36608 (高人七级) | 2015-06-19 17:09

我要晕了,服务器太老了,只能转程序,不能再装v4.0。 这个程序转着好多报错。

支持(0) 反对(0) ..00.. | 园豆:49 (初学一级) | 2015-06-19 17:48

@..00..: 什么服务器啊?连4.0都不能装?sever 2003都能装4.0的。

支持(0) 反对(0) 幻天芒 | 园豆:36608 (高人七级) | 2015-06-22 17:47

@幻天芒: 是2003的,但是那个服务器很老了,装v4.0跑不起来。。 我现在转化成v2.0后有的问题是我程序引用了一个dll文件,但是报的错是说未能引用他,我这是不知道什么情况了。

支持(0) 反对(0) ..00.. | 园豆:49 (初学一级) | 2015-06-23 12:00

@..00..: 这些库在2.0下是跑不起来的。你的程序感觉使用了Linq To SQL和Task等新版本的特性,转换的话,会有较多错误。你Server 2003的服务器,老一点,装个4.0也不至于跑不起来吧。个人建议,还是从服务器入手。

支持(0) 反对(0) 幻天芒 | 园豆:36608 (高人七级) | 2015-06-23 13:48
0

服务器是最便宜的东西了,一个服务器3万,你一年的工资总不至于不到3万吧。

我就不说那种5000元的服务器了。

收获园豆:1
爱编程的大叔 | 园豆:30698 (高人七级) | 2015-06-20 09:57

大叔,公司的服务器,我怎么给他买。。。。

支持(0) 反对(0) ..00.. | 园豆:49 (初学一级) | 2015-06-23 12:00
0

再老的服务器.Net Framework4.0还是可以安装的

收获园豆:1
蜗牛往前走 | 园豆:389 (菜鸟二级) | 2015-06-24 21:20
0

最好别高版本转低版本,服务器上面装4.0应该不难,只要你有权限

收获园豆:1
稳稳的河 | 园豆:4216 (老鸟四级) | 2015-06-25 10:57
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册