首页新闻找找看学习计划

spring.net NHibernate组件支持Oracle.ManagedDataAccess.dll驱动吗?

0
悬赏园豆:20 [待解决问题]

测试了下,配置spring.net的配置文件中 <db:provider id="DbProvider" provider="OracleODP-2.0" ***>,provider填写“OracleODP-2.0”只支持Oracle.DataAccess.dll驱动,现在升级NHibernate到NHibernate4(NHibernate4支持Oracle.ManagedDataAccess.dll驱动),却不知道结合spring.net的NHibernate组件,该如何配置,还望路过的大神指点下?(目前spring.net使用2.0.1版本和Spring.Data.NHibernate4,NHibernate使用4.0.4.4000版本)

LRanger的主页 LRanger | 初学一级 | 园豆:184
提问于:2015-09-02 10:03
< >
分享
所有回答(1)
0

从github上下载了源码,发现最新的spring.net date 组建已经支持Oracle.ManagedDataAccess.dll驱动,默认提共的OracleODP-Managed-12-4.0這个值,对应Oracle Managed provider V4.121.1.0,可能要使用其它版本需要自己改下

LRanger | 园豆:184 (初学一级) | 2015-09-02 11:26
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册