首页 新闻 搜索 专区 学院

嵌入式Linux对周立功开发板gpio操作时加载驱动模块出问题

0
悬赏园豆:10 [已关闭问题] 关闭于 2015-11-06 17:24

      将板子接口复用为gpio接口时需要加载驱动模块,有的教程上说/root下有gpio_driver.ko文件,可是我的没有,按照开发指南上方法拷到了板子里面输入命令后出现如下错误:在百度和博客里面都没有找到解决方法。

悬赏求解决方法:~)

学远爱吃鱼的主页 学远爱吃鱼 | 菜鸟二级 | 园豆:204
提问于:2015-11-04 22:10
< >
分享
所有回答(1)
0

确认下你的驱动程序在哪个Linux内核版本下编译的,你的板子上运行的是哪个版本,开发板的资料和板子上装的系统不是同步更新的,很有可能是版本不一致。Linux的驱动程序最好是自己用源代码重新编译一遍。

chenhust | 园豆:202 (菜鸟二级) | 2015-11-06 21:08

喔,估计是版本不一样,编译Linux的驱动程序要在内核里面编译吧,我内核编译还没看。正在研究中.....

支持(0) 反对(0) 学远爱吃鱼 | 园豆:204 (菜鸟二级) | 2015-11-07 12:14
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册