首页 新闻 搜索 专区 学院

最近想学bootstrap,但是用在项目中浏览器又不兼容,可以给点意见吗

0
悬赏园豆:5 [已解决问题] 解决于 2016-01-07 08:55

最近想学bootstrap,但是用在项目中浏览器又不兼容,可以给点意见吗

shashatongzhi的主页 shashatongzhi | 初学一级 | 园豆:183
提问于:2016-01-06 09:20
< >
分享
最佳答案
0

不知道你要兼容到什么程度

bootstrap3不兼容ie7 firefox3.6

bootstrap4不兼容ie8

但以上都是在尽可能不破坏大布局的情况下去做处理

若想要兼容到ie6 可以使用Bsie 他弥补了Bootstrap对IE6的不兼容 ,可以使ie6支持大部分bootstrap特性

详细请参考 http://www.bootcss.com/p/bsie/

收获园豆:5
默然沉醉 | 菜鸟二级 |园豆:352 | 2016-01-06 09:47
其他回答(2)
0

兼容IE8+,BS是优雅降级的。

幻天芒 | 园豆:36594 (高人七级) | 2016-01-06 09:26
0

如果要和IE浏览器低版本兼容,在页面头部添加一句

<meta http-equiv="X-UA-Compatible" content="IE=Edge">

强制使用IE浏览器的Edge模式

小桥轻轻 | 园豆:202 (菜鸟二级) | 2016-01-06 11:25
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册