首页 新闻 搜索 专区 学院

VS2013启动调试,打开浏览器自动跳转至本机IP

0
悬赏园豆:200 [待解决问题]

现在用VS2013做项目,用MVC4来做,在按F5键进行启动调试的时候,会自动启动火狐浏览器来调试,打开火狐浏览器后,地址栏会自动跳至本机IP地址:10.130.xxx.xxx,而不是通常的localhost:xxxx,而用IE浏览器则会正常显示为localhost:xxxx,这是什么原因?该怎么解决?

问题补充:

谁给帮帮我???关键是提示无法建立到10.130.xxx.xx服务器的连接,打不开程序,我想用火狐调试

各位大神们!该怎么解决啊???

各位大神,有遇到类似问题的吗?

sdzhaodan的主页 sdzhaodan | 初学一级 | 园豆:2
提问于:2016-01-19 11:38
< >
分享
所有回答(9)
0

看下你的hosts文件里面是否有localhost

jello chen | 园豆:7096 (大侠五级) | 2016-01-19 12:42

有localhost,

# localhost name resolution is handled within DNS itself.

#    127.0.0.1       localhost

#     ::1                localhost

很奇怪的是,用IE会正常显示为localhost:xxxx,我想用火狐调试,该怎么做?

支持(0) 反对(0) sdzhaodan | 园豆:2 (初学一级) | 2016-01-19 13:40
0

实在不行就通过IIS里面设置一个虚拟目录来调试,调试的方法也是有很多种的,不一定要F5,附加到进程也行

八八。 | 园豆:139 (初学一级) | 2016-01-19 15:06

我主要是想用火狐浏览器来调试,在网上查不到有关这方面的

支持(0) 反对(0) sdzhaodan | 园豆:2 (初学一级) | 2016-01-19 15:17

@sdzhaodan: 说的就是调试啊,用火狐一样可以附加到进程

支持(0) 反对(0) 八八。 | 园豆:139 (初学一级) | 2016-01-19 15:56
0

看你的项目属性启动选项中启动url是不是固定了

起个名字 | 园豆:377 (菜鸟二级) | 2016-01-19 15:47

没有固定,用IE可以,火狐和谷歌不行,

支持(0) 反对(0) sdzhaodan | 园豆:2 (初学一级) | 2016-01-19 15:57
0

站点->右键->属性->web->项目URL处看看,创建虚拟目录。

贫民窟大侠 | 园豆:4270 (老鸟四级) | 2016-01-20 10:47

谢谢,我昨天试过了,不行,我用vs2013重新创建了一个MVC4项目,还是不行,郁闷死我了,只能用IE,IE调试很难用啊

支持(0) 反对(0) sdzhaodan | 园豆:2 (初学一级) | 2016-01-20 11:05

@sdzhaodan: 你调试的地方那个绿色尖尖里面可以下拉选项,选择你想用的浏览器。

支持(0) 反对(0) 贫民窟大侠 | 园豆:4270 (老鸟四级) | 2016-01-20 11:08

@贫民窟大侠: 嗯嗯,是的,我现在是开发阶段,就想用火狐浏览器调试

支持(0) 反对(0) sdzhaodan | 园豆:2 (初学一级) | 2016-01-20 11:23
0

随便 点一个网页,点右键选择,浏览方式 。

选择火狐就行了

田麦成 | 园豆:1984 (小虾三级) | 2016-01-20 11:39

谢谢,结果还是那样,

支持(0) 反对(0) sdzhaodan | 园豆:2 (初学一级) | 2016-01-20 12:05
0

你这里选的是啥?

刘宏玺 | 园豆:14006 (专家六级) | 2016-01-20 13:35

这是我的设置,谢谢大家帮助,好郁闷

支持(0) 反对(0) sdzhaodan | 园豆:2 (初学一级) | 2016-01-20 15:51

@sdzhaodan: 那你只能是用ie启动调试,然后把连接复制到火狐浏览器了

支持(0) 反对(0) 刘宏玺 | 园豆:14006 (专家六级) | 2016-01-20 15:53
0

可以用Chrome调试,也许是用Chrome习惯了,感觉用Chrome调试比用Firefox爽多了。

nil | 园豆:667 (小虾三级) | 2016-01-20 15:36

Firefox和Chrome都不行,只有IE可以,我想用Firefox,是因为有Firebug

支持(0) 反对(0) sdzhaodan | 园豆:2 (初学一级) | 2016-01-20 15:52

@sdzhaodan: 你看下这个 http://www.webkaka.com/tutorial/server/2013/121611/


♦解决问题的思路:

1、ping一下localhost,这个是关键,看看是否能ping通,然后看解析到那个ip地址下去了
2、然后查看本机的hosts文件,看看是否有被修改,如果被修改,就改回正常的模式
3、解决问题本质,ipconfig看看网络是否正常,如果不正常就进行修复
4、用杀毒软件或者360等修复软件进行扫描,看看是否存在恶意插件或者病毒,然后清除,一劳永逸!
5、多动脑,想办法解决问题,善于用搜索引擎。

支持(0) 反对(0) nil | 园豆:667 (小虾三级) | 2016-01-20 18:38

@nil: 谢谢,还是不行,我的问题和这个有点类似

http://bbs.csdn.net/topics/390095379

支持(0) 反对(0) sdzhaodan | 园豆:2 (初学一级) | 2016-01-21 10:10

@sdzhaodan: 你的问题和这个一样 在前公司有个客户的电脑遇到过这个问题 

不一样的是那个客户的是双网卡,总是被重定向到内网网卡上导致的。

只是忘记当时是怎么解决的了  -_-#

支持(0) 反对(0) nil | 园豆:667 (小虾三级) | 2016-01-21 10:37

@sdzhaodan: 那个时候用的是nodejs,所以 这个配置是和VS是无关的,要看下是那个软件劫持了HTTP请求

支持(0) 反对(0) nil | 园豆:667 (小虾三级) | 2016-01-21 10:38

@sdzhaodan: 你安装的哪个版本的Firefox 是Firefox.cn还是Mozilla Firefox,我用的是这个 https://www.mozilla.org/en-GB/firefox/new/

支持(0) 反对(0) nil | 园豆:667 (小虾三级) | 2016-01-21 10:40

@nil: 我是用的火狐31.0,这个版本的浏览器以前是可以的,就在前天忽然出现这个状况了,然后我发现谷歌也是这样,只有IE还正常,我把火狐和谷歌都卸了重新安装也是不行

支持(0) 反对(0) sdzhaodan | 园豆:2 (初学一级) | 2016-01-21 11:09

@sdzhaodan: 要不要试试这个命令

netsh winsock reset 

前段时间我电脑edge浏览器没办法访问localhost,IE和Chrome可以,这个命令起作用了。

http://jingyan.baidu.com/article/6fb756ec83df00241858fb02.html

支持(0) 反对(0) nil | 园豆:667 (小虾三级) | 2016-01-21 11:40

@nil: 刚才试了下,还是不行,谢谢!

支持(0) 反对(0) sdzhaodan | 园豆:2 (初学一级) | 2016-01-25 08:24
0

检查你的路由文件是有特定的映射?

CCU | 园豆:238 (菜鸟二级) | 2016-01-20 16:52

没有特定的映射,下面是我的路由文件

支持(0) 反对(0) sdzhaodan | 园豆:2 (初学一级) | 2016-01-20 17:16
0

 lz,不知道这个问题解决了没有,我也遇到了

 

北京-小黑 | 园豆:202 (菜鸟二级) | 2016-09-26 17:29

 好了,原来是代理的问题,勾选  对本地地址不使用代理服务器  就可以了

支持(0) 反对(0) 北京-小黑 | 园豆:202 (菜鸟二级) | 2016-09-26 17:34
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册