首页新闻找找看学习计划

The dependency Ix-Async 1.2.5 does not support framework DNXCore,Version=v5.0

0
[已解决问题] 解决于 2016-03-06 18:09

用dotnet run运行asp.net core项目时,出现下面的错误:

/git/AboutUs/project.json(9,52): error NU1002: The dependency Ix-Async 1.2.5 does not support framework DNXCore,Version=v5.0.

project.json中第9行是:

"Microsoft.EntityFrameworkCore.SqlServer": "1.0.0-*"
问题补充:

这个问题与 Entity Framework Core有关,去掉 project.json 中下面的依赖配置,问题就消失。

"Microsoft.EntityFrameworkCore.SqlServer": "1.0.0-*"
dudu的主页 dudu | 高人七级 | 园豆:41299
提问于:2016-03-04 15:45
< >
分享
最佳答案
0

 在project.json中添加如下的配置后问题解决:

"netstandard1.3": {
      "imports": [
        "dotnet5.4",
        "portable-net452+win81"
      ]
}
dudu | 高人七级 |园豆:41299 | 2016-03-06 18:09
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册