首页新闻找找看学习计划

The dependency Ix-Async 1.2.5 does not support framework .NETCoreApp,Version=v1.0

0
悬赏园豆:10 [已解决问题] 解决于 2016-04-26 11:16

用dotnet run运行ASP.NET Core站点,出现下面的错误:

/git/AboutUs/project.json(15,55): error NU1002: The dependency Ix-Async 1.2.5 does not support framework .NETCoreApp,Version=v1.0.

对应的project.json条目是:

"Microsoft.EntityFrameworkCore.SqlServer": "1.0.0-*"

dotnet cli的版本是:

.NET Command Line Tools (1.0.0-rc2-002339)
问题补充:

EF 对 Ix-Async 的依赖见这里

dudu的主页 dudu | 高人七级 | 园豆:40900
提问于:2016-04-13 10:21
< >
分享
最佳答案
0

参考这篇博文.NET Core 1.0 RC2 历险之旅,将project.json中的frameworks配置:

"frameworks": {
  "netcoreapp1.0": {
    "imports": [
      "portable-net45+wp80+win8+wpa81+dnxcore50"
    ]
  }
}

改为:

"frameworks": {
  "netcoreapp1.0": {
    "imports": [
      "portable-net45+wp80+win8+wpa81+dnxcore50",
      "portable-net45+win8+wp8+wpa81",
      "portable-net45+win8+wp8"
    ]
  }
}

之后,问题解决。

dudu | 高人七级 |园豆:40900 | 2016-04-26 11:15
其他回答(1)
0

http://www.cnblogs.com/cmt/p/5263631.html
"imports": [  "portable-net452+win81" ]

收获园豆:10
苦逼师哥 | 园豆:204 (菜鸟二级) | 2016-04-13 11:05
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册