首页 新闻 搜索 专区 学院

T4模板相关问题,老司机进来看看

0
悬赏园豆:80 [已解决问题] 解决于 2016-06-27 11:59

上面给我一项目, ,让我先用自己的小项目连接数据库成功(确认能连上数据库),然后右键AttributeMapping.tt运行自定义模板成功,然后调试T4模板成功就可以了。结果运行自定义工具的时候就出了问题,两周了,就一直改,一直好不了,中途都重装系统了,百度的方法都试了,还是好不了。希望那个大神给个解决方法

问题补充:

问题看不清,我重发一个截图

ssrS丶的主页 ssrS丶 | 初学一级 | 园豆:37
提问于:2016-06-21 18:39
< >
分享
最佳答案
0

最简单的法子是你去下个oracle的win客户端安装一下.就解决了

收获园豆:80
吴瑞祥 | 高人七级 |园豆:28851 | 2016-06-21 21:31

Oracle数据库不安装,容易出问题,直接连公司的就行,
我自己的小项目能成功连接数据库,可以查询到里面的内容 ,说明连接这一块是没问题的

ssrS丶 | 园豆:37 (初学一级) | 2016-06-22 09:08

@shsf丶: 就是连接的客户端.代码里因为直接读DLL所以你只要引用就行.

T4里他要读机器配置.要不就自己去改.要不就撞他连接客户端.就几M.他会给你配.

吴瑞祥 | 园豆:28851 (高人七级) | 2016-06-22 09:46

@吴瑞祥: 我之前按照百度的改machine config中的dbfaverio什么的节点的内容,后来改毁了, 重启了,现在就不敢改里面的东西了

ssrS丶 | 园豆:37 (初学一级) | 2016-06-22 10:24

@shsf丶: 所以让你去装客户端啊...装完他会自己给你配好的.只要连接客户端就行.不用管理平台

吴瑞祥 | 园豆:28851 (高人七级) | 2016-06-22 11:32

@吴瑞祥: Oracle安装是不大可能了,改machine config还行,但是不会改呀 提示:找不到请求的.Net Framework Data Provider,可能没有安装,
我想应该是在<system.data> <DbProviderFactories>节点下加语句,之前加错没备份导致重装系统,这次不敢乱改

ssrS丶 | 园豆:37 (初学一级) | 2016-06-22 16:12

@shsf丶: 你还是不明白我说的是什么..不是让你装oracle. oracle会把.net的驱动封装成一个安装包.

你下载这个驱动就可以了. http://www.oracle.com/technetwork/cn/topics/dotnet/index-088718-zhs.html

吴瑞祥 | 园豆:28851 (高人七级) | 2016-06-22 18:28

@吴瑞祥: 我已经好了,用我经理告诉我的方法,不过还是谢谢你,把豆给你

ssrS丶 | 园豆:37 (初学一级) | 2016-06-27 11:59
其他回答(1)
0

你数据库是Oracle? 你先确认你这个.Net Framework Data Provider 组件好着没。

江宁织造 | 园豆:71 (初学一级) | 2016-06-21 20:14

蒽,Oracle数据库,这个组件在那里看安装没安装啊

支持(0) 反对(0) ssrS丶 | 园豆:37 (初学一级) | 2016-06-22 09:08
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册