首页 新闻 搜索 专区 学院

为什么现在的EFCore1.0,执行Migration就会报错?

0
悬赏园豆:100 [已解决问题] 解决于 2016-07-15 10:02

Unhandled Exception: System.IO.FileNotFoundException: Could not load file or assembly 'Microsoft.DotNet.Cli.Utils, Version=1.0.0.0, Culture=neutral, PublicKeyToken=adb9793829ddae60'. 系统找不到指定的文件。
   at Microsoft.EntityFrameworkCore.Tools.Program.Main(String[] args)

 

我看了下,'Microsoft.DotNet.Cli.Utils现在只有preview版本的,是没有RTM版本的问题么?

vbfool的主页 vbfool | 初学一级 | 园豆:176
提问于:2016-07-14 17:24
< >
分享
最佳答案
0

看下project.json中Microsoft.DotNet.Cli.Utils版本对不对,是不是1.0.0-preview2-003121

收获园豆:100
seayxu | 大侠五级 |园豆:5468 | 2016-07-14 19:53

没用,还是出这错误。

vbfool | 园豆:176 (初学一级) | 2016-07-15 09:20

@vbfool: 清除nuget缓存,然后dotnet restore

你可以看下:

https://github.com/aspnet/EntityFramework/issues/5934

https://github.com/aspnet/EntityFramework/issues/5886

seayxu | 园豆:5468 (大侠五级) | 2016-07-15 09:34

@SeayXu: 看来是可以了,谢谢

vbfool | 园豆:176 (初学一级) | 2016-07-15 10:02
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册