首页新闻找找看学习计划

Entity framework 生成的SQL如何设置兼容低版本的数据

0
悬赏园豆:20 [已解决问题] 解决于 2016-07-21 16:44

我使用的DB FIRST生成的.edmx ,我本地用的是SQL SERVER 2012 EXPRESS版本的数据库,

正式库使用的是SQL SERVER 2008 企业数据,我在更新edmx的时候,突然发现使用 data.Skip().Take()生成的SQL 带有SQL SERVER 2012特性的分页,OFFSET 210 ROWS FETCH NEXT 15 ROWS ONLY ,我这边在不想更换SQL SERVER 2012的前提下,如何生成兼容SQL SERVER 2008的SQL呢?

EF
问题补充:

我使用的EF 版本是 6.1.3

Dark_liu的主页 Dark_liu | 初学一级 | 园豆:127
提问于:2016-07-21 13:11
< >
分享
最佳答案
0

ef6有一个配置.百度下吧..在rc1里那个配置是无效的.core里不知道改了没

收获园豆:20
吴瑞祥 | 高人七级 |园豆:28731 | 2016-07-21 13:34

我用的是EF 6.1.31219和.core有什么关系?

 

Dark_liu | 园豆:127 (初学一级) | 2016-07-21 15:54

@Dark_liu: 没什么关系.你看下你的题目哪里有关于你的ef版本的东西?

吴瑞祥 | 园豆:28731 (高人七级) | 2016-07-21 15:59

@吴瑞祥: 谢谢提醒

Dark_liu | 园豆:127 (初学一级) | 2016-07-21 16:10
其他回答(1)
0

 通过DB First 生成edmx的时候,要注意生成的SQL 版本

Dark_liu | 园豆:127 (初学一级) | 2016-07-21 16:42
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册