首页 新闻 搜索 专区 学院

关于.net core 是否能使用现有.net framework 4.5类库的一些疑问。

0
[待解决问题]

.net  core 是 微软新发布的一个版本。那现有的.net framework 4.5的类库是否可以使用在.net core 的项目下。是否可以让他在linux 下正常运行。

yzy的主页 yzy | 菜鸟二级 | 园豆:317
提问于:2016-09-13 11:28
< >
分享
所有回答(2)
0

.NET 4.5的类库可以在.NET Core项目中使用,但付出的代价是无法在Linux上运行。

dudu | 园豆:38804 (高人七级) | 2016-09-13 12:04

那请问下最低版本是需要什么版本才可以在linux 下使用?

支持(0) 反对(0) yzy | 园豆:317 (菜鸟二级) | 2016-09-13 12:19

@yzy: 要用.NET Core Framework,在prject.json中的体现是:

{
  "frameworks": {
    "netcoreapp1.0": {}
  }
}
支持(0) 反对(0) dudu | 园豆:38804 (高人七级) | 2016-09-13 13:08
0

fframework不能在linux下用

吴瑞祥 | 园豆:28841 (高人七级) | 2016-09-13 12:29
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册