首页新闻找找看学习计划

server2012 R2 IIS部署站点 用localhost 可以正常,但用IP地址访问总是返回404

0
[已解决问题] 解决于 2017-01-11 22:39

server2012 R2 IIS部署站点 用localhost 可以正常,但用IP地址访问时 登录页面加载正常,但是点击登录页面的登录按钮回发时就直接返回404,不知什么情况?点击登录按钮 如果是 localhost 访问正常,如果换为IP地址 则直接跳到404 页面!

小驴的主页 小驴 | 初学一级 | 园豆:27
提问于:2016-10-28 10:42
< >
分享
最佳答案
0

cmd telnet一下你的80端口是不是能通

奖励园豆:5
新手娃娃菜 | 菜鸟二级 |园豆:256 | 2016-10-28 10:47

 页面可以访问!但ajax请求 或者 点击登录页面的登录按钮就直接 404 了!但如果在服务器上用localhost来访问一切正常,但再服务器上或者局域网内的其它电脑上 用 ip来访问 页面可以出来 但ajax请求 或者点击登录页面上的登录按钮 就直接404 了!

小驴 | 园豆:27 (初学一级) | 2016-10-28 10:54

@小驴: http://10.120.16.119:81/ ?????/login.aspx?ReturnUrl=%2f 

你发的这个请求地址是不是少项目名呀?这的问题吧

新手娃娃菜 | 园豆:256 (菜鸟二级) | 2016-10-28 11:29
其他回答(3)
0

IIS站点绑定呢.把配置截图发出来

吴瑞祥 | 园豆:28770 (高人七级) | 2016-10-28 11:08

好像需要开通博客才能上传图片哦!

支持(0) 反对(0) 小驴 | 园豆:27 (初学一级) | 2016-10-28 11:12

@小驴: 不用吧.在html前面不是有一个图片.

支持(0) 反对(0) 吴瑞祥 | 园豆:28770 (高人七级) | 2016-10-28 11:14

2016-10-28 03:02:03 10.120.16.119 GET /login.aspx ReturnUrl=%2f 81 - 10.120.16.119 Mozilla/5.0+(Windows+NT+6.3;+WOW64;+Trident/7.0;+rv:11.0)+like+Gecko - 200 0 0 0
2016-10-28 03:02:03 10.120.16.119 GET /view/getcaptcha.ashx - 81 - 10.120.16.119 Mozilla/5.0+(Windows+NT+6.3;+WOW64;+Trident/7.0;+rv:11.0)+like+Gecko http://10.120.16.119:81/login.aspx?ReturnUrl=%2f 302 0 0 0
2016-10-28 03:02:03 10.120.16.119 GET /view/404.html - 81 - 10.120.16.119 Mozilla/5.0+(Windows+NT+6.3;+WOW64;+Trident/7.0;+rv:11.0)+like+Gecko http://10.120.16.119:81/login.aspx?ReturnUrl=%2f 404 0 2 15
2016-10-28 03:02:03 10.120.16.119 GET / - 81 - 10.120.16.119 Mozilla/5.0+(Windows+NT+6.3;+WOW64;+Trident/7.0;+rv:11.0)+like+Gecko http://10.120.16.119:81/login.aspx?ReturnUrl=%2f 302 0 0 15
2016-10-28 03:02:26 10.120.16.119 POST /login.aspx ReturnUrl=%2f 81 - 10.120.16.119 Mozilla/5.0+(Windows+NT+6.3;+WOW64;+Trident/7.0;+rv:11.0)+like+Gecko http://10.120.16.119:81/login.aspx?ReturnUrl=%2f 302 0 0 0
2016-10-28 03:02:26 10.120.16.119 GET /404.html - 81 - 10.120.16.119 Mozilla/5.0+(Windows+NT+6.3;+WOW64;+Trident/7.0;+rv:11.0)+like+Gecko http://10.120.16.119:81/login.aspx?ReturnUrl=%2f 200 0 0 0

支持(0) 反对(0) 小驴 | 园豆:27 (初学一级) | 2016-10-28 11:14

@小驴: 不是这个...是说iis的站点配置..这个是日志.一般你说的这种情况就是绑定弄错了

支持(0) 反对(0) 吴瑞祥 | 园豆:28770 (高人七级) | 2016-10-28 11:15

@吴瑞祥: 找不到哪里上传图片,就是在编辑网站绑定 哪里 如果选择全部为分配 那在本机用localhost访问 功能一切正常,但如果 选择 ip 地址,则在本机访问 点击登录按钮 就直接404 了!

支持(0) 反对(0) 小驴 | 园豆:27 (初学一级) | 2016-10-28 11:20

@小驴: ReturnUrl=%2f 会不会是这个空格造成的..你删了看看..

支持(0) 反对(0) 吴瑞祥 | 园豆:28770 (高人七级) | 2016-10-28 13:00

@吴瑞祥: 姗了也一样!还有一个问题就是登录页上面有一个 ajax的请求 用谷歌浏览器F12看了一下 这个请求也是返回 404 ,但是直接把这个ajax请求的地址放到浏览器上面 有可以正常返回, 就是使用IP地址的方式时!     不知道是服务器的问题 还是 代码的问题! 还是那句话 在服务器上面 用localhost的 地址加端口访问一切功能正常! 还是以IP地址加端口来访问就返回404!

支持(0) 反对(0) 小驴 | 园豆:27 (初学一级) | 2016-10-28 14:24

是以IP地址加端口来访问就返回404!

支持(0) 反对(0) 小驴 | 园豆:27 (初学一级) | 2016-10-28 14:25

它不是一访问就返回404  而是登录页面加载正常 但是 点击登录按钮 回发时 就直接404 了,页面加载正常!

支持(0) 反对(0) 小驴 | 园豆:27 (初学一级) | 2016-10-28 14:28
0

看ajax那个url的路径~~~

liuxb、 | 园豆:661 (小虾三级) | 2016-10-28 15:24
0

你没绑定IP?

顾晓北 | 园豆:9741 (大侠五级) | 2016-11-02 11:24
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册