首页 新闻 搜索 专区 学院

c# 滚动的进度条问题

0
悬赏园豆:10 [已解决问题] 解决于 2009-08-18 17:34
我把ProgressBar的Style属性设为Marquee,在一台机器上跑能自动滚动,另外一台机器上跑时根本不动(前几天就是在这台上调的,一直以为是我程序的错误……),而且今天在我自己的电脑上也不能滚动了,连中间绿色的滚动条都没……  为什么?
在线等....
我的进度条是在窗体上添加的,不是网页内,也不用连数据库什么的,只是让它来回滚动即可
用c#语言
问题补充: 楼下的说的添加Application.EnableVisualStyles();这句,还是不行,不滚动啊,就是停留在刚开始的位置处
EEcho的主页 EEcho | 初学一级 | 园豆:3
提问于:2009-08-17 10:45
< >
分享
最佳答案
0

你是怎么设置Progress.Value 的,是不是在主线程中循环设置的?能把代码贴出来看一下吗?

收获园豆:10
eaglet | 专家六级 |园豆:17119 | 2009-08-17 12:49
这个根本就不用设置value值的,只要设置style值为Marquee,就会一直滚动,我昨天试,完全可以,今天就不行了,可是我什么代码都没有改啊
EEcho | 园豆:3 (初学一级) | 2009-08-17 15:20
是我没搞清楚。我有搜了一下,ProgressBarStyle.Marquee 不是所有平台上都可以运行的,只有下面平台支持 Windows Vista, Windows XP SP2, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP Starter Edition, Windows Server 2003, Windows Server 2000 SP4, Windows Millennium Edition, Windows 98 (以上来自MSDN) 你看一下你那太不能跑的机器是不是不在这个列表中 如果不是平台问题,你再参考下面几篇文章 http://social.msdn.microsoft.com/Forums/en-US/vcgeneral/thread/6cad1f6d-92fa-4cc0-a76f-99e1485c0ad5 http://www.codeguru.com/forum/showthread.php?t=324262 http://geekswithblogs.net/TimH/archive/2009/07/21/winform-progress-bar-marquee-style-not-working.aspx http://discuss.joelonsoftware.com/default.asp?dotnet.12.460028.1
eaglet | 园豆:17119 (专家六级) | 2009-08-17 19:23
@eaglet:Try inserting a progress bar as a resource instead of using CreateWindowEx(..), and set Marquee equal to TRUE, in the prograss bar control properties. 我不知道怎么把ProgressBar当做Resource添加?请问您知道吗?
EEcho | 园豆:3 (初学一级) | 2009-08-18 09:07
@eaglet:我的问题已经解决了,是用的多线程,只不过我以前用多线程时显示窗体,用的form.show,其实用该用showdialog() 不过还是谢谢你,我还是学到了东西
EEcho | 园豆:3 (初学一级) | 2009-08-18 17:33
其他回答(1)
0

设置progressbar的Style属性为marquee。打开Program.cs文件,在Main函数中加入Application.EnableVisualStyles();再试试看。

补充:

在Form_Load事件中加入

progressBar1.Style = ProgressBarStyle.Marquee;progressBar1.MarqueeAnimationSpeed = 100;按F5再试试。

另外,你看一下两台电脑上的.NET Framework版本是否一致。

重装.NET Framework试试。

Kinglee | 园豆:3158 (老鸟四级) | 2009-08-17 11:19
加上这句,还是不行,不滚动啊,就是停留在刚开始的位置处
支持(0) 反对(0) EEcho | 园豆:3 (初学一级) | 2009-08-17 11:26
我刚才已经在Form_Load里加了你说的那些,可是还是不行,在我自己的电脑上已经也不行了,我很纳闷,昨天明明可以
支持(0) 反对(0) EEcho | 园豆:3 (初学一级) | 2009-08-17 11:48
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册