首页新闻找找看学习计划

Error configuring application listener of class com.xxx.xxx.Xxx

0
悬赏园豆:10 [已解决问题] 解决于 2016-12-26 09:39

十二月 23, 2016 11:35:01 上午 org.apache.catalina.core.StandardContext listenerStart
严重: Error configuring application listener of class com.xxx.xxx.Xxx
java.lang.ClassNotFoundException: com.xxx.xxx.Xxx
at org.apache.catalina.loader.WebappClassLoaderBase.loadClass(WebappClassLoaderBase.java:1892)
at org.apache.catalina.loader.WebappClassLoaderBase.loadClass(WebappClassLoaderBase.java:1735)
at org.apache.catalina.core.DefaultInstanceManager.loadClass(DefaultInstanceManager.java:504)
at org.apache.catalina.core.DefaultInstanceManager.loadClassMaybePrivileged(DefaultInstanceManager.java:486)
at org.apache.catalina.core.DefaultInstanceManager.newInstance(DefaultInstanceManager.java:113)
at org.apache.catalina.core.StandardContext.listenerStart(StandardContext.java:5034)
at org.apache.catalina.core.StandardContext.startInternal(StandardContext.java:5634)
at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:145)
at org.apache.catalina.core.ContainerBase$StartChild.call(ContainerBase.java:1571)
at org.apache.catalina.core.ContainerBase$StartChild.call(ContainerBase.java:1561)
at java.util.concurrent.FutureTask.run(FutureTask.java:262)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
at java.lang.Thread.run(Thread.java:745)

问题补充:

各位大侠救命啊!!!!

看你灬梨涡浅笑的主页 看你灬梨涡浅笑 | 初学一级 | 园豆:96
提问于:2016-12-23 11:36
< >
分享
最佳答案
0

java.lang.ClassNotFoundException: com.xxx.xxx.Xxx

竟然可以报 com.xxx.xxx.Xxx 这个错,是不是你 包名类名都没改

收获园豆:10
代码飞了 | 菜鸟二级 |园豆:470 | 2016-12-23 15:21

com.xxx.xxx.Xxx 这是我公司同事写的,xxx是想说不把名字暴露出来

看你灬梨涡浅笑 | 园豆:96 (初学一级) | 2016-12-23 15:25

@看你灬梨涡浅笑: http://www.educity.cn/wenda/567137.html看看对你有用不

代码飞了 | 园豆:470 (菜鸟二级) | 2016-12-23 15:44

@代码飞了: 表示很迷茫

看你灬梨涡浅笑 | 园豆:96 (初学一级) | 2016-12-23 15:49

@看你灬梨涡浅笑: 也就是你看看你的jar是否有问题,

是不是缺少jar包,或者是jar包之间有冲突之类的

代码飞了 | 园豆:470 (菜鸟二级) | 2016-12-23 15:50

@代码飞了: 我已经仔细检查过了,没有问题。。。。崩溃了

看你灬梨涡浅笑 | 园豆:96 (初学一级) | 2016-12-23 15:54

@看你灬梨涡浅笑: 截图你的配置

代码飞了 | 园豆:470 (菜鸟二级) | 2016-12-23 15:57

@看你灬梨涡浅笑: 还有你先试试,clear一下项目,发布的tomcat删掉,重新启一下试试,如果不行,那你把配置的截图看看,或者你自己看看tomcat的日志文件找找错误

代码飞了 | 园豆:470 (菜鸟二级) | 2016-12-23 16:00

@代码飞了: 

看你灬梨涡浅笑 | 园豆:96 (初学一级) | 2016-12-23 16:00

@代码飞了: 第一张图是web。xml中的配置,第二张图是classes存放位置

看你灬梨涡浅笑 | 园豆:96 (初学一级) | 2016-12-23 16:02

@看你灬梨涡浅笑:那Xxx 没有这个类吧,

‘com.xxx.xxx.Xxx 这是我公司同事写的,xxx是想说不把名字暴露出来’

代码飞了 | 园豆:470 (菜鸟二级) | 2016-12-23 16:04

@看你灬梨涡浅笑: 不想暴露出来,那怎么识别你的包名和类名?

代码飞了 | 园豆:470 (菜鸟二级) | 2016-12-23 16:04

@代码飞了: 好吧,大哥,帮我看看吧,谢谢

看你灬梨涡浅笑 | 园豆:96 (初学一级) | 2016-12-23 16:08

@看你灬梨涡浅笑: 把配置文件里面的com.xxx.xxx.Xxx这个改一下,还原一下原来的包名类名

代码飞了 | 园豆:470 (菜鸟二级) | 2016-12-23 16:09

@代码飞了:配置文件中的数据都没有动过,

看你灬梨涡浅笑 | 园豆:96 (初学一级) | 2016-12-23 16:12
其他回答(1)
0

我也不知道改了什么就可以了。。。

看你灬梨涡浅笑 | 园豆:96 (初学一级) | 2016-12-26 09:38
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册