首页 新闻 搜索 专区 学院

错误 177 程序集“Microsoft.Office.Interop.Word, Version=14.0.0.0,版本高于所引用的程序集“office, Version=12.0.0.0,

0
悬赏园豆:10 [已解决问题] 解决于 2017-01-19 16:59

我引用的是Microsoft.Office.Interop.Word  Version=14.0.0.0,说我引用的程序集版本太高,但是我引用该低版本后自己要用到的一些枚举类型就会没有,所以我必须引用这个版本,但是又一直提示我引用的版本过高,网上说改web.config,也没见效果。求大神指点,感激不尽。

二环东路的主页 二环东路 | 菜鸟二级 | 园豆:206
提问于:2016-12-26 12:45
< >
分享
最佳答案
1

你想用Microsoft.Office.Interop.Word  Version=14.0.0.0所不支持的高版本,自己开发一套.NETFX才可以。否则就老老实实的,Microsoft.Office.Interop.Word  Version=14.0.0.0让运行在他所支持的版本上面。想想也知道,在10块钱一个的计算器上面是玩不了DOTA2的。

收获园豆:10
ensleep | 小虾三级 |园豆:1403 | 2016-12-26 13:36

谢谢,我还是引用了原来的低版本,一气之下用了别的方法预览Word,就没有引用Interop.word

二环东路 | 园豆:206 (菜鸟二级) | 2016-12-27 10:30
其他回答(1)
1

好像本地要安装这个版本的word,然后再修改配置文件

小球藻 | 园豆:259 (菜鸟二级) | 2016-12-26 14:29

谢谢,我试试

支持(0) 反对(0) 二环东路 | 园豆:206 (菜鸟二级) | 2016-12-27 10:31
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册