首页 新闻 搜索 专区 学院

未知的服务器错误:scriptManager

0
[已关闭问题]

出现以上问题,是不是需要在web.config中配置某些信息,还是上面控件需运行在framework3.5之上的。请各位赐教!

Jaryleely的主页 Jaryleely | 菜鸟二级 | 园豆:367
提问于:2009-08-24 15:12
< >
分享
其他回答(4)
0
Kinglee | 园豆:3158 (老鸟四级) | 2009-08-24 15:25
0

你要是允许使用Ajax控件,就必须建允许Ajax控件的网站,你要是建的不是允许使用Ajax 控件的网站,你要把webconfig 给改了  就行了

SuperMan123 | 园豆:205 (菜鸟二级) | 2009-08-24 15:26
0

<add assembly="System.Web.Extensions

known | 园豆:152 (初学一级) | 2009-08-24 17:01
0

配置文件问题,要不就是dll问题,看你用的是什么framework,2.0的需要配置ajax,3.5的就自带了,不用配置。不需要建立Ajax控件网站,只要配置对了就行。

Jerry Gao | 园豆:2 (初学一级) | 2009-08-24 18:45
0

这可能是因为你的服务器不支持微软自带的Ajax功能所致。

具体可以看这里

http://www.cnblogs.com/downmoon/archive/2009/06/03/1495176.html

 

如果是你们自己公司的服务器,

下载这个并安装

ASP.NET 2.0 AJAX Extensions 1.0

http://www.asp.net/ajax/downloads/archive/

 

如果是上传到租用的虚拟主机

你可以试试把机器上这两个文件上传到bin下

E:\Program Files\Microsoft ASP.NET\ASP.NET 2.0 AJAX Extensions\v1.0.61025\System.Web.Extensions.dll

E:\Program Files\Microsoft ASP.NET\ASP.NET 2.0 AJAX Extensions\v1.0.61025\System.Web.Extensions.Design.dll

邀月 | 园豆:25375 (高人七级) | 2009-08-24 18:50
清除回答草稿
   您需要登录以后才能回答,未注册用户请先注册